Problem testing modifs in yocto

Showing results for 
Search instead for 
Did you mean: 

Problem testing modifs in yocto

Contributor II

Hi everybody,

I am facing a problem modifying and testing for remapping my debug uart, so I am modifying .config, device tree and u-boot include files, below the location of files modified:




Buy the problem is at compilation time, if I run a  bitbake image compilation like:

bitbake core-image-minimal or bitbake -f core-image-base

Nothing changes in the deploy folder, then if I run a forced clean compilation

bitbake -c clean core-image-base

bitbake -f core-image-base

the generated .sdcard file is updated but I think that my modifications are not compiled

If I modify something in the source/somelayer/conf... the bitbake image ovverrides my modifications

I have tried too with the fsl-image-qt5

So, what is the correct procedure to modify some things like uboot, device tree, kernel config in the build folder and then force a compilation without update the files from the source?

Thanks in advance,


Labels (3)
0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

You can compile the kernel only.

For your reference.

Useful bitbake commands