Can vold support sata?

cancel
Showing results for 
Search instead for 
Did you mean: 

Can vold support sata?

633 Views
lqll
Contributor III

Hi community:

My environment is i.mx6q and android 4.4.2.

I mount sata in init.freescale.rc,like below:

# mount ext4 partitions

    mount_all /fstab.freescale

  mount ext4 /dev/block/sda1  /mnt/media_rw/sata

And boot log shows my sata is ready,like below:

ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)

ata1.00: ATA-8: ST500LT012-1DG142, 0001SDM1, max UDMA/133

ata1.00: 976773168 sectors, multi 16: LBA48 NCQ (depth 31/32)

ata1.00: configured for UDMA/133

scsi 0:0:0:0: Direct-Access     ATA      ST500LT012-1DG14 0001 PQ: 0 ANSI: 5

sd 0:0:0:0: [sda] 976773168 512-byte logical blocks: (500 GB/465 GiB)

sd 0:0:0:0: [sda] 4096-byte physical blocks

sd 0:0:0:0: [sda] Write Protect is off

sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00

sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA

And I can read/write my sata hard driver.

But I get nothing in /dev/block/vold.

I want to use MTP to read/write my sata hard driver,but because vold can't find sata,so I can't read/write my sata by MTP.

What Can I do?Please help me.

Thank You.

Labels (4)
0 Kudos
3 Replies

253 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hello Li,

       In android system ,you can 't use SATA directly, but you can use it as a ext_sd card.

       Attachment is on how to use SATA in android 2.3.7, very similar to android4.4.2 , so you can refer to it !

Regards,

Weidong

0 Kudos

253 Views
lqll
Contributor III

Hi Sun,

    I follow the pdf you give me,change my fstab.freescale like below:

-/devices/platform/sdhci-esdhc-imx.2/mmc_host/mmc1 /mnt/media_rw/extsd vfat defaults voldmanaged=extsd:auto

+/devices/platform/ahci.0/host0 /mnt/media_rw/extsd ext4 defaults voldmanaged=extsd:auto

     Then I can see SD card by MTP,but this file is empty.

     Where is my wrong?

Thank You,

Qiulong Li

0 Kudos

253 Views
sunfrank
Contributor I

Hi,Li

      have you solved this problem?  and I meet problem of SATA HDD too, I use IMX6Q + Linux 3.0.35, and I followed setting in the document above, but my system doesn't work well , information from serial port :

Uniform Multi-Platform E-IDE driver
ide-gd driver 1.18
ahci: SSS flag set, parallel bus scan disabled
ahci ahci.0: AHCI 0001.0300 32 slots 1 ports 3 Gbps 0x1 impl platform mode
ahci ahci.0: flags: ncq sntf stag pm led clo only pmp pio slum part ccc apst
scsi0 : ahci_platform
ata1: SATA max UDMA/133 mmio [mem 0x02200000-0x02200fff] port 0x100 irq 71
GPMI NAND driver registered. (IMX)

...

and later : 

...

ata1: SATA link down (SStatus 0 SControl 300)

0 Kudos