Probing a device connected on sdio lines?

cancel
Showing results for 
Search instead for 
Did you mean: 

Probing a device connected on sdio lines?

785 Views
gbiradar
Contributor IV


Hi Guys,

               I'm trying to write a simple application for imx6 board whose job is to read the information of device/module connected via sdio lines, the device can be 1 bit, 4 bit or spi also and the device/module  can be anything sd card, wireless etc...

I don't know where to start i have downloaded standard specification sdio, but application side how do i start because as per my knowledge sdio doesn't have any node in /dev/....

So if anyone has to probe the device basic idea how can we probe. this application should probe device id or vendor id in short status/category of the device connected on sdio lines. 

thanks & regards,

Ganesh Biradar

0 Kudos
4 Replies

146 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hi Ganesh,

      For your questions, I can just give you some sugggestions !

(1) Don't suggest you use uSDHC interface

If you use the interface, your device should support SDIO / SD / eMMC protocol.

(2) SPI interface recommended

If you connect your device to SPI port of i.MX6, you can use "spidev" driver in linux BSP, the way can help you save development time. As for how to use spidev, you can get more information from internet.

     Hope above adivce can help you !

Good luck!

Regards,

weidong

0 Kudos

146 Views
gbiradar
Contributor IV

Hi weidong.sun​,

Thanks to your reply, Actually I'm writing a generic code(application) that detect device connected which mainly bit 1/4 mode. for that i need a way to write a code how and where to start.

0 Kudos

146 Views
weidong_sun
NXP TechSupport
NXP TechSupport

Hello Ganesh,

     Anyway, you need to write a driver for your device at first, and in your driver, you should provide function interface for linux application. Otherwise, we can't access the device from linux application.

Regards,

weidong

0 Kudos

146 Views
vijay_jay5
Contributor II

Hi ,

My self i am VIjay. I am developing a custom board with

reference of sabresd but i am facing below problems.

1. EDID for HDMI is not working properly even i config with i2c properly.It

showing below message.

mxc_hdmi mxc_hdmi: No modes read from edid

mxc_hdmi mxc_hdmi: create default modelist

mxc_hdmi mxc_hdmi: Read EDID again

mxc_hdmi mxc_hdmi: No modes read from edid

mxc_hdmi mxc_hdmi: create default modelist

2. Actually i want to connect with the board 1280x768 @ 65Hz but it always

config to 640x480@60Hz

& I seen the EDID supportable parameters under

/driver/video/mxc/mxc_edid.c(also configured to 1280x720 @ 60Hz ) like

below. but display not working.

0 Kudos