Power-on latency exceeded

cancel
Showing results for 
Search instead for 
Did you mean: 

Power-on latency exceeded

2,522 Views
jamesmin
Contributor II

I got following warning message from the kernel a few times per hours at random during operation.

PU: Power-on latency exceeded, new value 64083334 ns

The "new value" varies each time. I don't think it would be a big problem, but I want to get rid of it in the first place thinking by giving proper initial value.

The chipset is iMX6Q and the dts have like below.

gpc: gpc@020dc000 {

                                compatible = "fsl,imx6q-gpc";

                                reg = <0x020dc000 0x4000>;

                                interrupts = <0 89 IRQ_TYPE_LEVEL_HIGH>,

                                             <0 90 IRQ_TYPE_LEVEL_HIGH>;

                                pu-supply = <&reg_pu>;

                                clocks = <&clks IMX6QDL_CLK_GPU3D_CORE>,

                                         <&clks IMX6QDL_CLK_GPU3D_SHADER>,

                                         <&clks IMX6QDL_CLK_GPU2D_CORE>,

                                         <&clks IMX6QDL_CLK_GPU2D_AXI>,

                                         <&clks IMX6QDL_CLK_OPENVG_AXI>,

                                         <&clks IMX6QDL_CLK_VPU_AXI>;

                                #power-domain-cells = <1>;

                        };

Is there any way to get rid of the message?

Labels (3)
5 Replies

338 Views
1282497337
Contributor II

hi james:
I also encounter this problem , and i want to know what's cause this problem, our kernel version is 3.14.52 
thx.
Alee 

0 Kudos

338 Views
veeranjaneyulug
Contributor III

I also face with same issue .while running my streaming application on  target board.can any body solve that issue .we are using kernel 3.14.28 version.

0 Kudos

338 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi James

one can try below patch

[PATCH v2 4/7] ARM: imx6: gpc: Add observed worst case latencies -- Linux Device Tree

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

0 Kudos

338 Views
jamesmin
Contributor II

Hi igor,

Thank you for the reply.

But the patch was a bit old, so I can't use for my 3.14.28 kernel.

I assume this warning message is not critical because my application is working for now.

But if you find any other sugguestion, it would be appreciated.

James.

338 Views
juliocruz
Contributor III

Hi James, Igor,

You got any news about this issue?

Thanks

0 Kudos