Postgresql i.mx28

cancel
Showing results for 
Search instead for 
Did you mean: 

Postgresql i.mx28

Jump to solution
234 Views
alexandrglukhov
Contributor III

Hello, I have an i.MX28, and I installed PostgreSQL with help of Buildroot. Now I want to configure postgresql, I mean, I want to set database destination, name, username and password, port but I don't know how to do it. And I have not enough experience in it. I tried search config files and tried run initdb and createdb on i.mx28, but unsuccessfully. When I run the i.mx, I get the following messages:

Initializing postgresql data base...

The files belonging to this database system will be owned by user "postgres".

This user must also own the server process.

The database cluster will be initialized with locale "C".

The default database encoding has accordingly been set to "SQL_ASCII".

The default text search configuration will be set to "english".

Data page checksums are disabled.

fixing permissions on existing directory /var/lib/pgsql ... ok

creating subdirectories ... ok

selecting default max_connections ... 100

selecting default shared_buffers ... 64MB

creating configuration files ... ok

creating template1 database in /var/lib/pgsql/base/1 ... ok

initializing pg_authid ... ok

initializing dependencies ... ok

creating system views ... ok

loading system objects' descriptions ... ok

creating collations ... sh: locale: not found

ok

No usable system locales were found.

Use the option "--debug" to see details.

creating conversions ... ok

creating dictionaries ... ok

setting privileges on built-in objects ... ok

creating information schema ... ok

loading PL/pgSQL server-side language ... ok

vacuuming database template1 ... ok

copying template1 to template0 ... ok

copying template1 to postgres ... ok

syncing data to disk ... ok

WARNING: enabling "trust" authentication for local connections

You can change this by editing pg_hba.conf or using the option -A, or

--auth-local and --auth-host, the next time you run initdb.

Success. You can now start the database server using:

    /usr/bin/postgres -D /var/lib/pgsql

or

    /usr/bin/pg_ctl -D /var/lib/pgsql -l logfile start

done

Starting postgresql: server starting

OK

So, it seems, that postgreSQL works, and create database template with user postgres.

Can anybody help me in it? I have no idea, how to do it.

Labels (2)
0 Kudos
1 Solution
80 Views
b36401
NXP TechSupport
NXP TechSupport

I'm afraid PostgreSQL configuration falls far outside the scope of Freescale Community.
I can suggest you PostgreSQL Documentation:

http://www.postgresql.org/docs/8.3/static/runtime-config.html

View solution in original post

0 Kudos
1 Reply
81 Views
b36401
NXP TechSupport
NXP TechSupport

I'm afraid PostgreSQL configuration falls far outside the scope of Freescale Community.
I can suggest you PostgreSQL Documentation:

http://www.postgresql.org/docs/8.3/static/runtime-config.html

View solution in original post

0 Kudos