Openssl Installation In Yocto Image and Configuration

cancel
Showing results for 
Search instead for 
Did you mean: 

Openssl Installation In Yocto Image and Configuration

887 Views
devendrasinghba
Contributor II

Hi Everyone,

I want to connect with websites using "Secure HTTP" protocol for that I have installed openssl_1.0.2h in Yocto Image but I am unable to connect with google.com ( Note: I have tried to connect with different sites but here I am taking example of "google.com" ) using secure HTTP protocol (i.e. When I am trying to Run the following command "wget https://google.com", then I am getting Network is unreachable error.). Here is the log for command run:

root@imx6qsabresd:~# wget https://google.com
Connecting to google.com (216.58.196.110:443)
wget: error getting response: Network is unreachable

I am able to ping the google.com (i.e. Internet is available on board). Here is the log of ping command:

root@imx6qsabresd:~# ping google.com
PING google.com (216.58.196.110): 56 data bytes
64 bytes from 216.58.196.110: seq=0 ttl=56 time=8.656 ms
64 bytes from 216.58.196.110: seq=1 ttl=56 time=8.578 ms
64 bytes from 216.58.196.110: seq=2 ttl=56 time=8.704 ms
^C
--- google.com ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 8.578/8.646/8.704 ms
root@imx6qsabresd:~#

And also I am able to connect with the google.com using insecure HTTP protocol (i.e. "wget http://google.com" is downloading its index.html ). Here is the log for the command run:

root@imx6qsabresd:~# wget http://google.com
Connecting to google.com (216.58.196.110:80)
Connecting to www.google.co.in (216.58.200.3:80)
index.html 100% |***********************************************************************************************************************| 12452 0:00:00 ETA
root@imx6qsabresd:~#

So why it is not connecting with URL's (i.e. webites) using "https"  protocol, is there any openssl configuration is required or any other dependencies package need to be installed.

Labels (2)
0 Kudos
3 Replies

63 Views
b36401
NXP TechSupport
NXP TechSupport

It seems port 433 (https) is disabled somewhere with network configuration (possibly on the router).
You need to check it.

Please note that wget supports proxy. So you can simply set https_proxy option if you have some local proxy server in your network.

By the way let me remind one more usefull option regarding to https: --no-check-certificate.
This option avoids certificate verification.
It is not related to current connectivity issue however there is a chance that when you fix network configuration you met certificate issue next.

Have a great day,
Victor

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

63 Views
devendrasinghba
Contributor II

I have checked about port 443, it is not disabled in Router by running the same command on the Ubuntu Machine, it is running without any problem. So I don't think there is a problem with router configuration. There is some other problem.

0 Kudos

63 Views
b36401
NXP TechSupport
NXP TechSupport

You can doublecheck if it the issue is connected to network connectivity not to wget itself with the command like "telnet google.com 443":

$ telnet google.com 443
Trying 74.125.232.227...
Connected to google.com.
Escape character is '^]'.

If you are getting something like "Unable to connect to remote host: Connection refused" instead of "Connected"
it means that port 443 is closed on some point between telnet and google.com.

Also for diagnostic please try "curl https://google.com" instead of wget. You can get some more output.

Have a great day,
Victor

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos