MX53 streaming problem -blog archive

cancel
Showing results for 
Search instead for 
Did you mean: 

MX53 streaming problem -blog archive

107 Views
prannoy
Contributor I

I am using MX53qsb with ltib.

Now i am facing a problem streaming using gst-launch.

I run this commands,

Mx53:

  gst-launch-0.10 -v v4l2src device=/dev/video0 ! video/x-raw-yuv,width=320,height=240 !  mfw_ipucsc ! mfw_vpuencoder width=320 height=240 codec-type=std_mjpg ! rtpjpegpay ! udpsink host=192.168.1.110 auto-multicast=false port=5000 sync=false

Host(ubuntu 11.10):

   gst-launch -vvv  udpsrc port=5000 ! 'application/x-rtp, media=video, payload=96, clock-rate=90000, encoding-name=JPEG' ! rtpjpegdepay ! ffdec_mjpeg ! xvimagesink

I am getting incorrect image30-stream.jpg like this.

Any one can tell me suggestion......? 

Tags (1)
0 Kudos
4 Replies

22 Views
Bhavana
Contributor II

 I have successful in live streaming over the internal network...Can anyone help me in streaming the video from client machine to a browser....i.e., we should be capable of viewing the live streaming through the browser...

0 Kudos

22 Views
BrilliantovKiri
Senior Contributor I

Bhavana, for host you can use repository, e.g. for Debian aptitude install libjpeg, for board you can build libjpeg via ltib.

0 Kudos

22 Views
Bhavana
Contributor II

Missing libgstjpeg.so file...Can anyone please help us out in resloving the issue..
am trying to stream using smokeenc.

0 Kudos

22 Views
BrilliantovKiri
Senior Contributor I

Hello, with software encoding you will get correct image, I describe this here

0 Kudos