Integration of WiFi Module from SAMSUNG based on Atheros AR6003 on R10.3.2 on i.MX53

cancel
Showing results for 
Search instead for 
Did you mean: 

Integration of WiFi Module from SAMSUNG based on Atheros AR6003 on R10.3.2 on i.MX53

776 Views
Contributor I

Hi All,

   We have build a custom tablet and are using WiFi module from Samsung SWL-A30H.

- Hardware Interface: SDIO interface

   Please find the log which i am getting when wifi is enabled on the Android Menu

AR6000: configuration opcode 7 is only used for RTOS systems, not Linux systems
AR6K: ** HIF layer does not support scatter requests (17)
wmi_control_rx() : Unknown id 0x101e
Add Filter 0 = 33:33:00:00:00:01
Keep Filter 0 = 33:33:00:00:00:01
Keep Filter 0 = 33:33:00:00:00:01
Add Filter 1 = 01:00:5e:00:00:01
ADDRCONF(NETDEV_UP): wlan0: link is not ready

Software: R10.3.2 SMD BSP customized for custom board

  

     Please help us in solving the issue.

Thanks and Regards,
Gupta

Labels (1)
0 Kudos
5 Replies

37 Views
Contributor V

The error log is like the following:

D/wpa_supplicant( 2348): ctrl_iface bind(PF_UNIX) failed: Address already in use
D/wpa_supplicant( 2348): ctrl_iface exists, but does not allow connections - assuming it was leftover from forced program termination
D/wpa_supplicant( 2348): Successfully replaced leftover ctrl_iface socket '/data/system/wpa_supplicant/wlan0'
D/wpa_supplicant( 2348): wlan0: Added interface wlan0

This is caused by permission. we should add the following in the init.rc. This bug has been fixed in our newest 53smd software R10.3.2. You can also get it from there.

mkdir /data/system 0775 system system
173 mkdir /data/system/wpa_supplicant 0771 wifi wifi
174 chmod 0771 /data/system/wpa_supplicant

0 Kudos

37 Views
Contributor I

Please find the requested log.

Thanks and Regards,
Gupta

0 Kudos

37 Views
Contributor V

Can you change the debug log level from info to debug in external/wpa_supplicant_ath/wpa_supplicant/main.c? Then recatch the logcat log.

params.wpa_debug_level = MSG_INFO;------------>params.wpa_debug_level = MSG_DEBUG; 

0 Kudos

37 Views
Contributor I

Please find the netcfg output and attached the logcat file for the same.

bash-3.2# netcfg
lo       UP    127.0.0.1       255.0.0.0       0x00000049
usb0     DOWN  0.0.0.0         0.0.0.0         0x00001002
tunl0    DOWN  0.0.0.0         0.0.0.0         0x00000080
gre0     DOWN  0.0.0.0         0.0.0.0         0x00000080
sit0     DOWN  0.0.0.0         0.0.0.0         0x00000080
wlan0    UP    0.0.0.0         0.0.0.0         0x00000003

Please review the same and let us know.

Thanks and regards,
Gupta

0 Kudos

37 Views
Contributor V

The log has no problem.

Please help to get more information through the following:

Firstly, running "netcfg" command in soncole to see if wlan0 net interface is on "up" state.

Secondly, If wlan0 is already on "up" state, please catch whole logcat information to me. 

0 Kudos