Linux kernel debugging on i.MX8 Quad Max MEK board using Lauterbach

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Linux kernel debugging on i.MX8 Quad Max MEK board using Lauterbach

Jump to solution
844 Views
vzeric
Contributor III

Hello

I am trying to debug Linux kernel on IMX8QaudMax MEK board. I built image using Yocto Project. I am using Kirkstone 5.15. I have configured kernel to enable debug symbols (works fine with simulator, but I can only load vmlinux to simulator since I don't have license for simulator). I connected Lauterbach to JTAG connector over JTAG- GEN2 Adapter Card that came with my board. I am using ARMv8-A/R probe.

The problem happens when I try to attach. Board just reboots and I get next warning:
Warning: CO:0 Erros occurred during initialization of master core, error=0x8c

I tried to attach to the board when board is set to boot from SD card, but SD card is not inserted. I would expect to get bus error, but I am getting this same warning...
I have also custom board that uses imx8qm and I can use same image, and on custom board I am able to debug, everything works fine.

My question is, should I apply some HW patch to IMX8QuadMax MEK board to enable debugging using JTAG? I have two MEK boards and I have same behavior with both boards...
I really have never seen this warning. Does anyone have any hints? Thanks!
Best regards,
Vanja

0 Kudos
1 Solution
746 Views
vzeric
Contributor III

I followed all steps from document you sent me and still I have same issue. But I made some progress with updating Trace32 to last supported version for my license. Warning disappeared.
Anyway thank you, I appreciate your help, this document is really helpful!
Best regards,
Vanja

View solution in original post

0 Kudos
2 Replies
779 Views
joanxie
NXP TechSupport
NXP TechSupport

pls refer to the enclosed file and check if your debug steps are correct or not

0 Kudos
747 Views
vzeric
Contributor III

I followed all steps from document you sent me and still I have same issue. But I made some progress with updating Trace32 to last supported version for my license. Warning disappeared.
Anyway thank you, I appreciate your help, this document is really helpful!
Best regards,
Vanja

0 Kudos