KITPFPGMEVME Programmer Rev. B Software Problems.

cancel
Showing results for 
Search instead for 
Did you mean: 

KITPFPGMEVME Programmer Rev. B Software Problems.

Jump to solution
281 Views
Richard1z
Contributor II

Hi,

I got a KITPFPGMEVME Programmer Rev. B today.

The instruction card in the box said I need to download:

KIT0100GUI.zip

NI Visa 5.1.2

Microsoft .Net Framework 4.0

whereas the KTPFPGHWUG document says:

"Necessary software and drivers include:
• KITPFGUI4.0.zip: Graphical User Interface (GUI) for PF family of Power Management Integrated Circuits."

Do I need KIT0100GUI.zip or KITPFGUI4.0.zip ?

I suspect I only need KITPFGUI4.0.zip because I have a Rev B programmer ?

Do I need NI Visa 5.1.2 ?

I will not be happy if I have to pay for this as well - just to program a few devices !

I installed KITPFGUI4.0 on Windows 7 and got the error "Object reference not set to an instance of an object" when I try to connect to the USB device.

Any help welcomed - this is a very poorly documented product !!!!!

I have a prototype PCB sitting on my desk and I am stalled until I can get my PF-200 programmed.

Richard.

Labels (2)
0 Kudos
1 Solution
83 Views
reyes
NXP TechSupport
NXP TechSupport

Hello Richard,

For your question "I suspect I only need KITPFGUI4.0.zip because I have a Rev B programmer?"

Correct, but just to make sure, I’m assuming that you are using the GUI Revision 4.0 and the KITPFPGMEVME REV B (KITPFPGMEVME should have a sticker on the bottom with “REV B” on it like the one with the sticker on the attached picture), please correct me if I’m wrong.

Rev B programmer you DO NOT need the National Instruments drivers (NI-VISA), it works off the HID driver (KITPFGUI_4.0).

Please use KITPFGUI 4.0 for the KITPFPGMEVME REV B.

And follow the instruction from the “KITPFPGMEVME Rev B Programmer” document.http://cache.freescale.com/files/analog/doc/user_guide/KTPFPGHWUG.pdf

Other useful document: “KITPFGUI 4.0 Graphical User Interface”.

For further questions related to this case, I would request to be handled using your existing Service Request (SR) at this moment.

Have a great day,
Jose Reyes

-------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-------------------------------------------------------------------------------

View solution in original post

0 Kudos
1 Reply
84 Views
reyes
NXP TechSupport
NXP TechSupport

Hello Richard,

For your question "I suspect I only need KITPFGUI4.0.zip because I have a Rev B programmer?"

Correct, but just to make sure, I’m assuming that you are using the GUI Revision 4.0 and the KITPFPGMEVME REV B (KITPFPGMEVME should have a sticker on the bottom with “REV B” on it like the one with the sticker on the attached picture), please correct me if I’m wrong.

Rev B programmer you DO NOT need the National Instruments drivers (NI-VISA), it works off the HID driver (KITPFGUI_4.0).

Please use KITPFGUI 4.0 for the KITPFPGMEVME REV B.

And follow the instruction from the “KITPFPGMEVME Rev B Programmer” document.http://cache.freescale.com/files/analog/doc/user_guide/KTPFPGHWUG.pdf

Other useful document: “KITPFGUI 4.0 Graphical User Interface”.

For further questions related to this case, I would request to be handled using your existing Service Request (SR) at this moment.

Have a great day,
Jose Reyes

-------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-------------------------------------------------------------------------------

View solution in original post

0 Kudos