Imx6 Autoboot stop

cancel
Showing results for 
Search instead for 
Did you mean: 

Imx6 Autoboot stop

241 Views
Contributor I

Hello Team.

I am using the imx6q sabresd board i flash the android9 image for the board and  i set the uboot environmental variable 

"setenv bootdelay 0" and saveenv, reset, after doing this i am able to set the uboot environmental variable by pressing the enter key but i am expecting it should not allow me to enter in uboot mode, please have a look for the below logs,

can any one help what could be the reason for this. 

Normal Boot
Hit any key to stop autoboot: 0
=>
=> printenv
baudrate=115200
board_name=SABRESD
board_rev=MX6Q
bootcmd=boota mmc2
bootdelay=0
ethact=ethernet@02188000
ethaddr=00:04:9f:05:b6:6e
ethprime=eth0
fastboot_dev=mmc2
fdt_high=0xffffffff
fdtcontroladdr=49f0adf0
initrd_high=0xffffffff
loadaddr=0x12000000
soc_type=imx6q
splashpos=m,m
tee=no

Environment size: 320/8188 bytes

Thanks in Adavance and Best Regards

SGN

0 Kudos
3 Replies

38 Views
NXP TechSupport
NXP TechSupport

Hello Nandish SG,

If I understand correctly you wish to block access to the uboot console, so it won’t be accessible.

Besides reducing the boot delay to zero you may also enable the “silent” mode. However, if you want to really secure your application it would be better to set a password to access uboot or enable other security measures.

I hope this helps!

Regards,

0 Kudos

38 Views
Contributor I

Hello  Gusarambula,

Thanks for your quick reply and what you understand is correct "wish to block access to the uboot console, so it won’t be accessible", so i set the bootdelay=0 and even in the boot args it show autoboot is zero  Hit any key to stop autoboot: 0 so why it enter to the uboot mode if i press any key,  it should not be enter uboot mode right, 

so if not going to the uboot mode then no need to set the any password to access the uboot. 

can you please reply to me how to enable the “silent” mode.

Thanks and Best Regards

Nandish S.G

0 Kudos

38 Views
NXP TechSupport
NXP TechSupport

Hello Nandish SG,

You may enable silent mode by writing the environment variable silent to 1:

Uboot-> setenv silent 1

Uboot-> saveenv

I hope this helps!

Regards,

0 Kudos