IMX287 : Migrating to glibc 2.18+ from current toolchain gcc-4.4.4-glibc-2.11.1-multilib-1.0

cancel
Showing results for 
Search instead for 
Did you mean: 

IMX287 : Migrating to glibc 2.18+ from current toolchain gcc-4.4.4-glibc-2.11.1-multilib-1.0

292 Views
thiagarajamural
Contributor I

I see that the current toolchain of the IMX28 BSP is using the gcc version 4.4.4 and glibc 2.11. There is a requirement to update the glibc to 2.18 version in our IMX28 based device project. I think even the gcc tool chain provided in the IMX6 BSP is not supporting newer glibc(only glibc 2.13). Will it cause any harm  or effect if we try to use new gcc tool chain with glibc greater than 2.18.

Thanks,

Murali

Labels (2)
0 Kudos
2 Replies

126 Views
gusarambula
NXP TechSupport
NXP TechSupport

Hello Thiagaraja Muralidaran,

The Yocto 3.10.53-1.1.0 BSP release for the i.MX6 has glibc-2.19, hopefully it can serve as reference. However, I don’t think it has been tested for the i.MX28 and that Yocto release is for a newer linux kernel.

0 Kudos

126 Views
thiagarajamural
Contributor I

Hi gusarambula,

I'll try to extract the toolchain provided by Yocto BSP for IMX6 and use it for building IMX28 BSP.  It might be another solution. Also trying another approach to update only the glibc section in the current IMX28 toolchain(gcc version 4.4.4 and glibc 2.11).  Managed to build the glibc 2.22 with the new Linux kernel headers and binutils. Next thing would be to install this new glibc 2.22 to current toolchain of GCC version 4.4.4.

Thanks,

Murali

                                                             Re: IMX287 : Migrating to glibc 2.18+ from current toolchain gcc-4.4.4-glibc-2.11.1-multilib-1.0                                                    

                      

     gusarambula     Employee                        

0 Kudos