How to run Qt5 example application(s) on EPD?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to run Qt5 example application(s) on EPD?

Jump to solution
817 Views
ajithpv
Contributor V

Hi All,

As part of my current task, I'm working on the EPDC of i.MX6 SoloLite. I'm using the Linux kernel version 3.14.28 (Rev. L3.14.28_1.0.0-ga) with Yocto build.

When I'm running the "./mxc_epdc_fb_test.out" from the board, it is working and showing the test cases one by one. This is confirmed that, the display and basic set-up is working proper.

Since, I want to try Qt sample applications (provided in the rootfs) on E-INK EPD, I tried to run it from the board as below.

STEP 1: Qt applications are running directly from the console

I have run the Qt5 sample applications that are present inside "/usr/share" folder individually. But I'm getting the below error.

Qt Warning: Could not find a location of the system's Compose files. Consider setting the QTCOMPOSE environment variable.

Qt Warning: Could not find a location of the system's Compose files. Consider setting the QTCOMPOSE environment variable.

libGL error: dlopen /usr/lib/dri/vivante_dri.so failed (libGL.so.1.2: cannot open shared object file: No such file or directory)

libGL error: unable to load driver: vivante_dri.so

libGL error: failed to load driver: vivante

libpng warning: iCCP: known incorrect sRGB profile

libpng warning: iCCP: known incorrect sRGB profile

STEP 2 : Running the Qt application through "mxc_epdc_x11_fb_test.out" test application

I have tried to run the test application "mxc_epdc_x11_fb_test.out" under unit_tests folder. This application shows a desktop window with Qt application icons on EPD (display).

When I touch a Qt application icon (via touch panel), then Qt application is working!, without any error.

So, I would like to know what I'm missing. Could anyone please tell me, how I can run the Qt5 application as STEP1 (This is the one I required). How to resolve the above errors?

Looking forward to your reply...

Thank you in advance,
Ajith P V

Labels (4)
1 Solution
178 Views
ajithpv
Contributor V

Qt required X11 back end and necessary EPD update routines for running the sample applications.

Closing the thread since, I found a workaround to run it.

View solution in original post

2 Replies
179 Views
ajithpv
Contributor V

Qt required X11 back end and necessary EPD update routines for running the sample applications.

Closing the thread since, I found a workaround to run it.

View solution in original post

178 Views
ajithpv
Contributor V

Any updates?

0 Kudos