How to build Qt for validation image

cancel
Showing results for 
Search instead for 
Did you mean: 

How to build Qt for validation image

Jump to solution
356 Views
Mihan
Contributor IV

Hi 

I want to upgrade my device(imx6dl)'s system from 4.1.15 to the latest version 4.14.98.

But I found the rootfs in the image I downloaded on i.MX Software and Development Tools | NXP is great but without Qt.

Then I found a document about how to build Qt Building QT for i.MX6, but the git doesn't work.

If I cross-complie the Qt, I can't get the toolchain for qt (e.g.fsl-imx-x11-glibc-x86_64-meta-toolchain-qt5-cortexa9hf-neon-toolchain-4.1.15-2.1.0)

So how to do that, I don't want to build image by following the user's guide, it spends a lot of time.

Regards

Mihan

Labels (1)
0 Kudos
1 Solution
230 Views
Mihan
Contributor IV

Sun1zigorpadykov

Thank you so much.

I seem understand it.

I have to build the image by myself (by git-repo) so that I can use bitbake to make the rootfs with Qt, rigth.

Here is the picture of the image I download on the website, I don't think I can bitbake it.

I will redo again by following the yocto guide.

Best wish

Mihan

Image 4.14.98.bmp

View solution in original post

0 Kudos
5 Replies
231 Views
Mihan
Contributor IV

Sun1zigorpadykov

Thank you so much.

I seem understand it.

I have to build the image by myself (by git-repo) so that I can use bitbake to make the rootfs with Qt, rigth.

Here is the picture of the image I download on the website, I don't think I can bitbake it.

I will redo again by following the yocto guide.

Best wish

Mihan

Image 4.14.98.bmp

View solution in original post

0 Kudos
230 Views
Sun1z
Contributor III

just run "bitbake fsl-image-qt5-validation-imx" or "bitbake fsl-image-qt5", the later is a wrapper of the former.

however, there is a issue in 4.14.98, you need modify:

SDCARD_ROOTFS ?= "${IMGDEPLOYDIR}/${IMAGE_NAME}${IMAGE_NAME_SUFFIX}.ext4"

in sources/meta-fsl-bsp-release/imx/meta-bsp/conf/machine/include/imx-base.inc otherwise you will fail in bitbake.

and if you want to generate deb package, you need modify:

LOCALVERSION = "-${@'${SRCBRANCH}'.replace('_', '-')}"

in sources/meta-fsl-bsp-release/imx/meta-bsp/recipes-kernel/linux/linux-imx_4.14.98.bb.

you can write these modifications in corresponding bbappend file.

btw: the recent release is 5.4.3 but not 4.14.98, you can find it at imx-manifest - i.MX Release Manifest.

from the changelog, 5.4.3-1.0.0 is GA release and 2.0.0 is beta release, for 5.4.3_1.0.0, at least it can be built without error.

0 Kudos
230 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Mihan

one can try steps in sect.5.6.7 Qt 5 Yocto Guide in Linux L4.14.98_2.0.0 Documentation

or

https://boundarydevices.com/boot2qt-embedded-qt5-image-and-toolchain-zeus-release/ 

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos
230 Views
Mihan
Contributor IV

Thanks.

But the stpes in sect.5.6.7 is about the differences between commercial or open-source license and QtWebEngine.

I will read an try the steps in the second website.

Regards

Mihan

0 Kudos
230 Views
igorpadykov
NXP TechSupport
NXP TechSupport

pastedImage_1.jpg

Best regards
igor

0 Kudos