Gstreamer stuck on FSL Community BSP version

cancel
Showing results for 
Search instead for 
Did you mean: 

Gstreamer stuck on FSL Community BSP version

391 Views
yaolinchang
Contributor I

Hi All,

     We download FSL Community BSP  source code as below:

repo init -u https://github.com/Freescale/fsl-community-bsp-platform -b fido

and execute gstreamer for camera capture.

Our command as below:

gst-launch-1.0 imxv4l2src device=/dev/video1 ! 'video/x-raw, format=(string)NV12, width=1920, height=1080, framerate=(fraction)60/1' ! imxvideoconvert_g2d rotation=3 ! video/x-raw,format=RGB16,width=1080,height=1920 ! autovideosink &

However, gstreamer will be stuck.

The log as below:

root@imx6qsabresd:~# WARNING: erroneous pipeline: could not link imxv4l2videosrc0 to imxvideoconvert_g2d0

^C

[1]+  Done(1)                 gst-launch-1.0 imxv4l2videosrc device=/dev/video1 ! 'video/x-raw, format=(sk

utovideosink &d rotation=3 ! video/x-raw,format=RGB16,width=1080,height=1920 ! a

[1] 462

root@imx6qsabresd:~# mxc_v4l_open 1627

mxc_v4l_open 1639

ERROR: v4l2 capture: slave not found!

mxc_v4l_open 1627

mxc_v4l_open 1756

   Setting mclk to 24 MHz

  ioctl_dev_init 3331

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

ARRAY_SIZE(ov5640_mode_info_data) 2

====== IMXV4L2SRC: 4.0.3 build on Nov 19 2015 20:53:47. ======

Setting pipeline to PAUSED ...

display(/dev/fb0) resolution is (1200x1920).

set color key:00010mxc_v4l2_output v4l2_out.32: Bypass IC.

203

====== OVERLAYSINK: 4.0.3 bumxc_v4l2_output v4l2_out.32: Bypass IC.

ild on Nov 19 2015 20:53:49. ======

display(/dev/fb0) resolution is (1200x1920).

display(/dev/fb0) resolution is (1200x1920).

Attempt to unlock mutex that was not locked

Have any one know what is happen?

Best Regards,

Yao

0 Kudos
2 Replies

35 Views
christophertele
Contributor III

hy,

maybe you have chosen the false "capture-mode". i thoght that it is not possible to capture in "full HD" from ov5640. is you pipeline running without that filter stuff: 'video/x-raw, format=(string)NV12, width=1920, height=1080, framerate=(fraction)60/1' ??

cheers

0 Kudos

35 Views
Yuri
NXP TechSupport
NXP TechSupport

Hello,

  The message "ERROR: v4l2 capture: slave not found!" - may mean, that

camera hardware is not supported in the selected software configuration.

Please check, using the gst-inspect command what cams and features are supported

in Your configuration. Perhaps  "device=/dev/video1" is not correct selection.


Have a great day,
Yuri

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos