FLEX-iMX8M Mini can't use VPU encoder

cancel
Showing results for 
Search instead for 
Did you mean: 

FLEX-iMX8M Mini can't use VPU encoder

Jump to solution
287 Views
Senior Contributor I

Hi,

I'm using FLEX iMX8M Mini (by Technexion). I built image OS with Yocto. I also install gstreamer-1.0. 

VPU encoder:

vpu: vpuenc_h264: IMX VPU-based AVC/H264 video encoder
vpu: vpuenc_mpeg4: IMX VPU-based MPEG4 video encoder
vpu: vpuenc_h263: IMX VPU-based H263 video encoder
vpu: vpuenc_jpeg: IMX VPU-based JPEG video encoder
vpu: vpudec: IMX VPU-based video decoder

But when I run gstreamer command to record video, I get this:

Setting pipeline to PAUSED ...
[ERR] Error: Unable to obtain system rev information
[ERR] IOSystemInit() failure.
ERROR: Pipeline doesn't want to pause.
ERROR: from element /GstPipeline:pipeline0/vpuenc_h264:vpuenc_h264-0: Could not initialize supporting library.
Additional debug info:
../../../../git/gst-libs/gst/video/gstvideoencoder.c(1627): gst_video_encoder_change_state (): /GstPipeline:pipeline0/vpuenc_h264:vpuenc_h264-0:
Failed to open encoder
Setting pipeline to NULL ...
Freeing pipeline ...

This is the first time I use iMX8M Mini. I have no idea with this issue. 

I also receive this message each 10 seconds.

[ 1122.994574] alloc_contig_range: [60240, 60254) PFNs busy
[ 1133.230580] alloc_contig_range: [60240, 60254) PFNs busy
[ 1143.485313] alloc_contig_range: [60240, 60254) PFNs busy
[ 1153.733584] alloc_contig_range: [60240, 60254) PFNs busy

What should I do now ?

Thank you so much,

Toan

Labels (1)
0 Kudos
1 Solution
209 Views
Senior Contributor I

I changed to using Yocto image OS (built by Technexion). Now VPU is working well now. 

View solution in original post

0 Kudos
1 Reply
210 Views
Senior Contributor I

I changed to using Yocto image OS (built by Technexion). Now VPU is working well now. 

View solution in original post

0 Kudos