Ethernet ping issue

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Ethernet ping issue

1,064 Views
vishakh
Contributor III

Hi,

I am using i.MX6 based custom SOM module with ksz9031 Ethernet phy. Linux kernel being used is 3.0.35.

When I do ping test using below procedure, ping fails randomly.

  1. Boot the board
  2. Ping the host machine.
  3. poweroff and reboot the board.

Ping fails to receive the packets with 100% packet loss. To reproduce the issue sometimes I need to reboot the board even for 1000 times. 

It seems like link is going down while pinging. 

What might be causing problem to link to go down? Might this be because of phy skew settings?

Thanks and Regards,

Vishakh

0 Kudos
4 Replies

657 Views
xing
Contributor I

Have you resolve the problem?

0 Kudos

657 Views
igorpadykov
NXP Employee
NXP Employee

Hi Vishakh

in general your considerations regarding skew make sense.

Also one can pay attention to power-up sequence, when power board,

check that all power supplies were fully discharged and not other

powered peripherals were attached to processor.

Best regards
igor
-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

657 Views
vishakh
Contributor III

Hi Igor,

Thank you for the reply.

I will check on power-up sequence.

Regarding skew values, what is the criteria to decide pcb requires skew settings and how to decide those values.

Regards,

Vishakh

0 Kudos

657 Views
igorpadykov
NXP Employee
NXP Employee

Hi Vishakh

for skew please check Table 62. RGMII Signal Switching Specifications

i.MX6DQ Datasheet

http://cache.freescale.com/files/32bit/doc/data_sheet/IMX6DQCEC.pdf

Best regards
igor

0 Kudos