Error while running autorun-v4l2.sh

cancel
Showing results for 
Search instead for 
Did you mean: 

Error while running autorun-v4l2.sh

752 Views
chaitanyadhere
Contributor I

Hello all,

             I'm getting the following error when I run autorun-v4l2.sh. My board is based on IMX6 Solo. My kernel version is 3.14.28. PLease find the error log below:

root@imx6-solo:/unit_tests# ./autorun-v4l2.sh

=============== test start from Thu Jan 1 00:01:08 UTC 1970 ==============================

Checking for devnode: /dev/video0

autorun-v4l2.sh: PASS devnode found: /dev/video0

Checking for devnode: /dev/video16

autorun-v4l2.sh: PASS devnode found: /dev/video16

Checking for devnode: /dev/video17

autorun-v4l2.sh: PASS devnode found: /dev/video17

imx-ipuv3 2400000.ipu: WARNING: adapt panel end blank lines

Display in U:800x480p-0

Running test case: ./mxc_v4l2_output.out -iw 1024 -ih 768 -ow 800 -oh 480 -d /dev/video17 -r 0 -vf 0 -hf 0 -fr 60

g_in_width = 1024, g_in_height = 768

g_display_width = 800, g_display_height = 480

driver=mxc_vout, card=DISP3 FG, bus=, version=0x00030e1c, capabilities=0x04000002

fmt RGB565: fourcc = 0x50424752

fmt BGR24: fourcc = 0x33524742

fmt RGB24: fourcc = 0x33424752

fmt RGB32: fourcc = 0x34424752

fmt BGR32: fourcc = 0x34524742

fmt NV12: fourcc = 0x3231564e

fmt UYVY: fourcc = 0x59565955

fmt YUYV: fourcc = 0x56595559

fmt YUV422 planar: fourcc = 0x50323234

fmt YUV444: fourcc = 0x34343459

fmt YUV420: fourcc = 0x32315559

fmt YVU420: fourcc = 0x32315659

fmt TILED NV12P: fourcc = 0x50564e54

fmt TILED NV12F: fourcc = 0x46564e54

fmt YUV444 planar: fourcc = 0x50343434

cropcap.bounds.width = 800

cropcap.bound.height = 480

cropcap.defrect.width = 800

cropcap.defrect.height = 480

v4l2_output test: Allocated 4 buffers

VIDIOC_QUERYBUF: length = 1179648, offset = 0

VIDIOC_QUERYBUF: length = 1179648, offset = 1179648

VIDIOC_QUERYBUF: length = 1179648, offset = 2359296

VIDIOC_QUERYBUF: length = 1179648, offset = 3538944

start time = 78 s, 963763 us

mxc_sdc_fb fb.18: timeout when waiting for flip irq

mxc_sdc_fb fb.18: timeout when waiting for flip irq

mxc_sdc_fb fb.18: timeout when waiting for flip irq

mxc_sdc_fb fb.18: timeout when waiting for flip irq

mxc_sdc_fb fb.18: timeout when waiting for flip irq

mxc_sdc_fb fb.18: timeout when waiting for flip irq

The issue is the lines highlighted. Also when I run any code to capture images from camera I get the following logs:

ERROR: v4l2 capture: mxc_v4l_dqueue timeout enc_counter 0

VIDIOC_DQBUF failed.

Are the two issues related to each other ? Is there any fix for these issues ? My kernel version is 3.14.28

Thanks,

Chaitanya Dhere

0 Kudos
4 Replies

189 Views
igorpadykov
NXP TechSupport
NXP TechSupport

Hi Chaitanya

issues not related to each other. Flip irq is discussed on

Re: imx6q mxc_sdc_fb timeout when waiting for flip irq

and caused by improper IPU reinitialization, if uboot initialize IPU

for logo then kernel initializes it again. One can disable uboot logo.

Second "v4l2 capture" error is due to camera: it is not connected or

different than one used on Sabre SD boards (OV5640,OV5642). New camera

should be ported, examples can be found on Community, like

Porting ov5645 to android jb4.2.2

i.MX6 DualLite + OV5653

Best regards

igor

-----------------------------------------------------------------------------------------------------------------------

Note: If this post answers your question, please click the Correct Answer button. Thank you!

-----------------------------------------------------------------------------------------------------------------------

189 Views
chaitanyadhere
Contributor I

Hello,

         The flip irq issue is solved. Thanks for your help. However, the

ERROR: v4l2 capture: mxc_v4l_dqueue timeout enc_counter 0

VIDIOC_DQBUF failed.

issue is till remaining. The autorun-v4l2.sh test is successfully running. The camera driver has been written for our custom camera. The same driver was working with 3.10.17 kernel. It is showing us the above error in 3.14.28 kernel.

What can be the issue ?

Thanks,

Chaitanya Dhere

0 Kudos

189 Views
chaitanyad
Contributor I

Hello,

          Are there any solutions on the same ? Kindly let us know what can be the possible causes when an error like

ERROR: v4l2 capture: mxc_v4l_dqueue timeout enc_counter 0

VIDIOC_DQBUF failed.

shows up ?

Thanks,

Chaitanya Dhere

0 Kudos

189 Views
igorpadykov
NXP TechSupport
NXP TechSupport

this error does not point to any specific misconfiguration,

probably you can try to compare IPU settings or sources with working 3.10.17 test.

~igor

0 Kudos