Error adding new packages on ltib

Showing results for 
Search instead for 
Did you mean: 

Error adding new packages on ltib

Contributor II

i want to add olsrd to the packages list, to build it in to the imx28evk using ltib.

I followed the next steps:

1. copy source in /opt/freescale/pkgs

2. create file source_name.md5

md5sum source_name > source_name.md5

3. create directory in <you_ltib_dir>dist/lfs-5.1/<you_package> and copy spec-file to it

After this you can use ltib for build package:

1. ./ltib -m prep -p package.spec

2. ./ltib -m scbuild -p package.spec

3. ./ltib -m scdeploy -p package.spec

i also added on config/userspace/packages.lkc (alphabetic order)

      config PKG_OLSRD

           bool "olsrd"

and on config/userspace/pkg_map (build order)

       PKG_OLSRD = olsrd

but, when i execute the comand:

./ltib -m prep -p olsrd.spec

this error appear:

plc@ubuntu:~/ltib$ ./ltib -m prep -p olsrd.spec

Processing: olsrd


Build path taken because: build key set, no prebuilt rpm,

Testing network connectivity


Try olsrd-current.tar.bz2.md5 from the GPP

06:25:58 ERROR 404: Not Found.

Try olsrd-current.tar.bz2 from the GPP

06:25:58 ERROR 404: Not Found.

Can't get: olsrd-current.tar.bz2 at ./ltib line 790.

f_prep() returned an error, exiting



Exiting on error or interrupt

I know that olsrd is not able at gpp, but i thought this was enought to found it on ppp or lpp, i think im missing something, but i dont know what.

Thanks for the help.

Labels (1)
0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

It is possible that the .librc is not configured with the necessary options in order to download the file from a local repository. Do you have the olsrd-current.tar.bz2 file on the rmp/SOURCES path ?

I would recommend reading the following link on the “Where do the sources get downloaded from (what is the LPP/GPP/PPP)” section for information on how the download is handled when it cannot be downloaded.

0 Kudos