Enabling GPS module on Sabre Platform Device.

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Enabling GPS module on Sabre Platform Device.

2,933 Views
Foppa
Contributor I

Hi!

I'm facing problem when trying to enable GPS AH1613 module on Sabre boards UART3 port(/dev/ttymxc2). Module seems to be offline, tried with gpsd and gpsctl daemonds and both gives same result. GPS is powered by gps_power_on() function in board-mx6q_sabresd.c file. This function enables 3v15 and gps_en. I added also gps_reset(first up to reset and after minor delay down to disable reset) for test if I can reset module first but got same results. So, how can I enable module correctly?

Labels (2)
8 Replies

1,264 Views
rejitantony
Contributor II

Hello,

         I am facing a similar problem. I'm using AH-1613 gps module. I was able to get 3.15V at VCC(pin 11) , 1.5V at V_BCKP(pin 5) . I'm still unable to get any data form the gps (/dev/ttymxc2). I'm using Linux 3.14 . Has any one solved the problem ? Do we need to initiate the communication by sending any commands to GPS module?

0 Kudos

1,264 Views
YixingKong
Senior Contributor IV

Foppa

We are sorry for getting back to you so late. Are you still stuck with the issue? If you have somehow to resolved the

issue, can we close the discussion? If you still need Freescale help, please feel free to contact us.

Thanks,

Yixing

0 Kudos

1,264 Views
sachusanal
Contributor III

Hai Yixing ,

I am using sabresd Evk board with Android  lollipop prebuilt image. i am using the same AH1613 Module

could you pleas help me Enable GPS Module ?

Awaiting your favourable reply

Regards

Sachu

0 Kudos

1,264 Views
ericyu
Contributor II

Hello Yixing

We already solved this problem.

But I don't how to close this discussion on i.MX community.

Thanks

於 西元2014年02月18日 11:10, Yixing Kong 提到:

>

Freescale Community <https://community.freescale.com/>

<https://community.freescale.com/>

>

Enabling GPS module on Sabre Platform Device.

reply from Yixing Kong

<https://community.freescale.com/people/YixingKong?et=watches.email.thread>

in /i.MX Community/ - View the full discussion

<https://community.freescale.com/message/380835?et=watches.email.thread#380835>

>

0 Kudos

1,264 Views
rejitantony
Contributor II

Hi Eric

Did you solved the GPS interface problem. I'm using AH-1613 gps module. I was able to get 3.15V at VCC(pin 11) , 1.5V at V_BCKP(pin 5) . I'm still unable to get any data form the gps (/dev/ttymxc2). I'm using Linux 3.14 . Do we need to initiate the communication by sending any commands to GPS module?

I also tried in android and saw that some commands are being send to the GPS module and some data is been received. I was able to capture these data using Wave Surfer and send the same data to the module in Linux 3.14. But still my gps is not responding.

If have solved the issue can you outline the steps you have followed to solve the issue

0 Kudos

1,264 Views
alvind
Contributor III

Hello,

Can you please outline the steps on how to enable the GPS Module for i.MX6Q SABRE SD?

Regards,

Alvin

0 Kudos

1,264 Views
YixingKong
Senior Contributor IV

Eric

Thank you. I will take care of this. You may either click Correct Answer or click "Mark as assumed answered" on the top of this screen.

Regards,

Yixing

0 Kudos

1,264 Views
ericyu
Contributor II

I have this GPS issue too.

Who can teach me how to enable GPS on IMX6 SDP

My BSP is R13.4.1

0 Kudos