Build Code Signing Tool 3.3.1

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Build Code Signing Tool 3.3.1

3,099 Views
panli
Contributor II

Dear all,

I was trying to build CST 3.3.1 from source code. I followed README.md in cst-3.3.1/code/back_end-hsm but couldn't find libfrontend.a.

Following is what I read from README.md:

## Compile backend

To compile backend and CST from souce

Compile the backend source code using the following command:

$ make

Options:
OPENSSL_PATH Specify prefix of path of OpenSSL

## Compile Code-Signing tool

Copy libfrontend.a to project source folder them compile CST using the following command:

 

This is what I have done

cst-3.3.1/code/back_end-hsm/src$ make clean

code/back_end-hsm/src$ make

 

Can you show me, where I can find the libfrontend.a file?

regards

Pan

 

7 Replies

3,090 Views
Yuri
NXP Employee
NXP Employee

@panli 
Hello,

   You can use the libfrontend.a  from CST 3.3.0 package.

Regards,
Yuri.

0 Kudos
Reply

3,084 Views
panli
Contributor II

Hi Yuri,

I found 3.3.1 in this link https://www.nxp.com/webapp/sps/download/license.jsp?colCode=IMX_CST_TOOL_NEW&appType=file1&location=...

 

But cannot find 3.3.0. Can you give me a link to 3.3.0 package?

 

regards

Pan

0 Kudos
Reply

3,083 Views
Yuri
NXP Employee
NXP Employee

@panli 
Hello,

  I've sent You package directly.

Regards,
Yuri.

0 Kudos
Reply

704 Views
donjacobvellathottam
Contributor III

Hi @Yuri ,

can you share the cst tool 3.3.0 with me also please.

Regards,

Don

0 Kudos
Reply

829 Views
DanWhite
Contributor I

Hi Yuri,

I am also trying to build Code Signing Tool on 3.3.1 and am getting the same error:


    make: *** No rule to make target '../../../linux64/lib/libfrontend.a', needed by 'cst'. Stop.

 

Is it possible for you to link me to 3.3.0 so I can get the libfrontend.a file?

0 Kudos
Reply

2,299 Views
zachary_forbush
Contributor II

Hello @Yuri , we've run into the same issue: the current 3.3.1 release doesn't have libfrontend.a. Trying to compile the CST for Windows.

I tried with the libfrontend.a from 3.1.0, but I'm not sure that it's compatible -- getting compilation errors.

Can you please provide the libfrontend.a for v3.3.0/v3.3.1?

 

Thanks!

0 Kudos
Reply

3,057 Views
panli
Contributor II

Hi Yuri,

we compared the source code in cst-3.3.1/code/back_end-hsm with that from 3.3.0. And didn't find difference.

Since we have already had 3.3.0 in our system, we didn't make the upgrading to 3.3.1.

regards

Pan