Boot issue using prebuilt android images for i.mx6Q -SABRE (MCIMx6Q-SDB) from SD card(SD3)

cancel
Showing results for 
Search instead for 
Did you mean: 

Boot issue using prebuilt android images for i.mx6Q -SABRE (MCIMx6Q-SDB) from SD card(SD3)

Jump to solution
3,101 Views
hemalgandhi
Contributor III

I am trying to boot-up the i.mx6Q quad core (MCIMx6Q-SDB) board by downloading the p rebuilt  demo images for android .I have perform the following steps.

1.  I have inserted the 8 GB SD card in SD3(J507) slot. I am using MFG tool( version Mfg tools Rel-12.09.01_GA_MX6Q_UPDATER)  to download images on SD card.I have put required images in android folder of mfgtool updater. (boot.img, recovery.img,system.img and u-boot.bin)

2. I am  settings boot switch sw6 as 00001100(1 to 8 bit) while it is in download mode. When MFG tool completed its download to the SD card, i power off the board and then reset the SW6 switch to 01000010 ( MMC2 (SD3) boot) but its not booting up.

3.  Some time it does not get the "booti" command and some times it stuck in downloading the u image.

I have checked the SD card using fdisk command and found that it has only one partition instead of it should have 9 partition.

Is there any change in the step i mentioned above?. I am using prebuilt demo android images from (\image_imx-android-r13.4-ga_6qsabresd.tar\image_imx-android-r13.4-ga_6qsabresd\sabresd_6dq\SD) . Is there something missing here? Please help..

Thanks,

Hemal

Labels (1)
1 Solution
493 Views
hemalgandhi
Contributor III

Thanks Brett

It works..I have changed the profile name in cfg.ini to Android-SabreSD-eMMC and replace mmcblk0 with mmcblk1 in this Android-SabreSD-eMMC provided in ucl2.xml file.

Also i have changed the uboot argument as mentioned below on uboot command line.

setenv bootcmd booti mmc2 to boot from SD3 slot ( Using SD Card)

saveenv

With this above changes it booted with android OS on HDMI display.

Thanks for your help!!!!!!!!!!!!!!

View solution in original post

2 Replies
493 Views
admin
Specialist II

The mfgtool ucl2.xml does not have an Android -> SD programming profile, only -> eMMC.

This profile needs to be slightly modified to program the SD

(replace mmcblk0 with mmcblk1)

Verify the cfg.ini file is selecting this new SD profile.

You will also need to adjust the uboot commandline arguments to use the SD card.

Brett

494 Views
hemalgandhi
Contributor III

Thanks Brett

It works..I have changed the profile name in cfg.ini to Android-SabreSD-eMMC and replace mmcblk0 with mmcblk1 in this Android-SabreSD-eMMC provided in ucl2.xml file.

Also i have changed the uboot argument as mentioned below on uboot command line.

setenv bootcmd booti mmc2 to boot from SD3 slot ( Using SD Card)

saveenv

With this above changes it booted with android OS on HDMI display.

Thanks for your help!!!!!!!!!!!!!!

View solution in original post