Boot LTIB generated root file system with NFS

cancel
Showing results for 
Search instead for 
Did you mean: 

Boot LTIB generated root file system with NFS

982 Views
AlexanderZiegle
Contributor I

First, i have compiled and installed the LTIB contained in the package L2.6.35_11.03.00_ER_source.tar.gz under Ubuntu 10.04 on a real machine (no VM) according to the steps described in the documents "i.MX53 START Linux" and ltib_build_host_setup.pdf.

Then i configured LTIB for the i.MX53 QSB as target. The compilation finished without errors

and the /rootfs folder was created successfully. I have flashed  and setup u-boot to the micro-sd.

 

When i start the board first the kernel is loaded successfully over ethernet from the host. The kernel

then mounts the /rootfs directory via NFS. But then after loading many modules

the startup aborts with the following error message in the serial terminal:

...

gtk: creating gdk-pixbuf.loaders

pango: creating module list
starting pid 2218, tty '': '/sbin/getty -L ttymxc0 115200 vt100'
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
(EE) XKB: No components provided for device Virtual core keyboard

Backtrace (0 deep):

Fatal server error:
Segmentation fault caught

Can't deallocate console 2 Device or resource busy

arm-none-linux-gnueabi-gcc (4.4.4_09.06.2010) 4.4.4
root filesystem built on Wed, 11 May 2011 17:47:44 +0200
Freescale Semiconductor, Inc.

freescale login: matchbox-panel: failed to open displaymatchbox-desktop: unable to open display !
matchbox: can't open display! check your DISPLAY variable.
ts_open: No such file or directory

 

I have checked the folder /usr/share/X11 which contains only a text file. I have compared

the own generated rootfs with the rootfs contained in the demo image L2.6.35_11.03.00_ER_images_MX5X.tar.gz and it seams that many of files for X11 do not exist.

Is there a need to manually install packages with LTIB to the own build /rootfs ? I have checked

that all X11 packages are selected in LTIB before build the rootfs.

I have also tried the 11.01 packages but the behavior is the same.

 

What is wrong?

 

I have attached the complete output in the serial terminal and the u-boot configuration.

Labels (1)
0 Kudos
8 Replies

235 Views
Claude_Sylvain
Contributor I

>
> i still have the error :(
>
> root@freescale ~$ export DISPLAY=:0.0
> root@freescale ~$ Xfbdev -nolisten tcp -mouse mouse,,device=/dev/input/mice -key
> bd keyboard,,/dev/input/event4 &
> root@freescale ~$ (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
> (EE) XKB: No components provided for device Virtual core keyboard
> Kbd option key (/dev/input/event4) of value ((null)) not assigned!
> (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
> (EE) XKB: No components provided for device (unnamed keyboard)
>

- Euh...  Yes.  And this is what I got too :-(
  But, the X Window server errors are gone, and X Server and
  mouse support must work now :-)


Claude


0 Kudos

235 Views
G_rio
Contributor III

Hello Claude,

i still have the error :(

root@freescale ~$ export DISPLAY=:0.0
root@freescale ~$ Xfbdev -nolisten tcp -mouse mouse,,device=/dev/input/mice -key
bd keyboard,,/dev/input/event4 &
root@freescale ~$ (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
(EE) XKB: No components provided for device Virtual core keyboard
Kbd option key (/dev/input/event4) of value ((null)) not assigned!
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
(EE) XKB: No components provided for device (unnamed keyboard)

0 Kudos

235 Views
Claude_Sylvain
Contributor I

Hello Eduardo,


>
> After build QT i've tried to run a sample but unsuccessful.
>
> I got this error:
>
>    
>
> root@freescale ~$ export DISPLAY=:0.0
> root@freescale ~$ Xfbdev -mouse mouse,,device=/dev/input/mice -keybd
> keyboard,,/dev/input/event2 &
> root@freescale ~$ _XSERVTransSocketOpenCOTSServer: Unable to open socket
> for inet6
> _XSERVTransOpen: transport open failed for inet6/freescale:0
> _XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
> (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
> (EE) XKB: No components provided for device Virtual core keyboard
> Kbd option key (/dev/input/event2) of value ((null)) not assigned!
> (EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
> (EE) XKB: No components provided for device (unnamed keyboard)
>

- I think the "XKB" messages are not "fatal", and you can live with
  them.
  This is probably due to BSP not including the XKB configuration files.
  You have to supply these configurations files by yourself.

- To get rid of the "_XSERVTransOpen" error, just add the option
  "-nolisten tcp", when calling Xfbdev (in startx).


Claude.


0 Kudos

235 Views
G_rio
Contributor III

Hello guys,

After build QT i've tried to run a sample but unsuccessful.

I got this error:

 

root@freescale ~$ export DISPLAY=:0.0
root@freescale ~$ Xfbdev -mouse mouse,,device=/dev/input/mice -keybd keyboard,,/dev/input/event2 &
root@freescale ~$ _XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6
_XSERVTransOpen: transport open failed for inet6/freescale:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
(EE) XKB: No components provided for device Virtual core keyboard
Kbd option key (/dev/input/event2) of value ((null)) not assigned!
(EE) XKB: Couldn't open rules file /usr/share/X11/xkb/rules/base
(EE) XKB: No components provided for device (unnamed keyboard)

0 Kudos

235 Views
hr1z
Contributor I

I have the same issue not being able to start x windows. Did you find a solution?

0 Kudos

235 Views
LilyZhang
Contributor I

The error you saw is related to touch screen.

You can add the following changes in your rootfs /usr/bin/startx:

if [ -L /dev/input/ts0 ]; then
Xfbdev -mouse tslib,2,device=/dev/input/ts0 -mouse mouse,2,device=/dev/input/mice&
else
Xfbdev -mouse mouse,2,device=/dev/input/mice&
fi

If no touch screen is detected, don't initialize touch screen for Xfbdev.

0 Kudos

235 Views
AlexanderZiegle
Contributor I

Hello Claude.

 

Yes, i have configured Ltib with "FSL gnome release packages". First i also thought that

 had forgotten this option, but i don't.

 

Alexander


0 Kudos

235 Views
Claude_Sylvain
Contributor I

Hello Alexander,

- When configuring Ltib ("./ltib -m config"), have you selected
  "FSL gnome release packages" as the package profile?
  The default package profile is "Min profile", and to my experience
  seems to not include the X Window System.


Claude


0 Kudos