Wilink8 driver throughput on twrvf65gs10 connected via SDIO interface

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Wilink8 driver throughput on twrvf65gs10 connected via SDIO interface

Jump to solution
1,009 Views
amnawaseem
Contributor I

Hello All,

I have ported Wilink8 MCP 8.4 driver for twrvf65gs10 platform.

http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=TWR-VF65GS10

Platform has SDIO multiblock support with DMA. Wl18xx card has been switched to high speed mode ( 50 MHz).

Wl18xx driver has been ported to use Nucleus RTOS.

Currently cortex a5 CPU is running at 396 MHz.

I have measured throughput via iperf on it for Wilink8 driver and the results are as follows:

------------------------------------------------------------
Server listening on TCP port 5001
TCP window size: 256 KByte
------------------------------------------------------------

[ 6] local 0.0.0.0 port 5001 connected with 192.168.0.101 port 53336
[ ID] Interval Transfer Bandwidth
[ 6] 0.0-10.5 sec 8.00 MBytes 6.37 Mbits/sec

------------------------------------------------------------
Client connecting to 192.168.0.100, TCP port 5001
TCP window size: 256 KByte
------------------------------------------------------------
[ 3] local 192.168.0.101 port 50741 connected with 192.168.0.100 port 5001
[ ID] Interval Transfer Bandwidth
[ 3] 0.0-10.1 sec 7.88 MBytes 6.53 Mbits/sec

Is it a reasonable speed? What numbers are expected to get on twrvf65gs10 platform with Wl18xx module? On am335xevm. throughput is very high ( 50 Mbps ) but on vybrid platform, it is very low. Why this is so? Am i missing anything?

Labels (1)
0 Kudos
1 Solution
601 Views
CommunityBot
Community Manager
This an automatic process.

We are marking this post as solved, due to the either low activity or any reply marked as correct.

If you have additional questions, please create a new post and reference to this closed post.

NXP Community!

View solution in original post

0 Kudos
7 Replies
602 Views
CommunityBot
Community Manager
This an automatic process.

We are marking this post as solved, due to the either low activity or any reply marked as correct.

If you have additional questions, please create a new post and reference to this closed post.

NXP Community!
0 Kudos
602 Views
VilemZ
NXP Employee
NXP Employee

Hi Amna,

I haven't any experiences with Wilink8, but if you measure throughput, how you was connected? Connection from Vybrid to some router was by wireless LAN and how standard was you use?


If you use standard IEEE 802.11b, is it OK.

If you use standard IEEE 802.11g - question is interferences, number of channel, etc...


Wifi can choose speed by interferences and when looses packets.


Best regards

Vilem

0 Kudos
602 Views
amnawaseem
Contributor I

Hello Vilem,

Thanks a lot for your reply.

Yes Connection was by wireless LAN to TP Link Access Point.

I am using IEEE 802.11n standard.

Best Regards

Amna

On Tue, Feb 3, 2015 at 8:26 PM, Vilem Zavodny <admin@community.freescale.com

0 Kudos
602 Views
VilemZ
NXP Employee
NXP Employee

Hi Amna,

Ok and have you got correct settings for N standard on module? I read, that you can choose between a,b,g,n.

Best Regards

Vilem

0 Kudos
602 Views
amnawaseem
Contributor I

Hi Vilem,

Yes settings are correct for N standard on module. All the settings are

actually in firmware file which is provided by the vendor so these cannot

be incorrect. Yes, I can choose between different modes.

Thanks

Amna

On Wed, Feb 4, 2015 at 1:18 PM, Vilem Zavodny <admin@community.freescale.com

0 Kudos
602 Views
VilemZ
NXP Employee
NXP Employee

Hi Amna,

can you try send bigger block of data? Or can you compare with anything else?

And can you send me your settings on Vybrid, please? I can check it.

Best regards,

Vilem

0 Kudos
602 Views
karina_valencia
NXP Apps Support
NXP Apps Support

HI amnawaseem do you have the information requested?

0 Kudos