Vybrid TWR-SER version board can't enable ethernet connection, anybody know how to fix this?

cancel
Showing results for 
Search instead for 
Did you mean: 

Vybrid TWR-SER version board can't enable ethernet connection, anybody know how to fix this?

Jump to solution
585 Views
zitaoliu
Contributor II


New Vybrid (version twr-ser, the single ethernet port black board) can't get connection with the only one ethernet port, does anybody know how to configure the swith/jumpers or need solder somehing?

Thanks a lot,

1 Solution
151 Views
zitaoliu
Contributor II

Thanks very much, problem solved, I solder two caps on the top of C3 makes the ethernet works.

U-Boot 2013.07 (Oct 01 2015 - 00:13:47)

CPU:   Freescale Vybrid 600 family rev1.2 at 396 MHz

Reset cause: POR

Board: TWR-VF65GS10

DRAM:  128 MiB

WARNING: Caches not enabled

NAND:  256 MiB

MMC:   FSL_SDHC: 0

In:    serial

Out:   serial

Err:   serial

Net:   FEC

Hit any key to stop autoboot:  0

=>

=> ping 128.224.155.1

Using FEC device

host 128.224.155.1 is alive

=>

View solution in original post

7 Replies
152 Views
zitaoliu
Contributor II

Thanks very much, problem solved, I solder two caps on the top of C3 makes the ethernet works.

U-Boot 2013.07 (Oct 01 2015 - 00:13:47)

CPU:   Freescale Vybrid 600 family rev1.2 at 396 MHz

Reset cause: POR

Board: TWR-VF65GS10

DRAM:  128 MiB

WARNING: Caches not enabled

NAND:  256 MiB

MMC:   FSL_SDHC: 0

In:    serial

Out:   serial

Err:   serial

Net:   FEC

Hit any key to stop autoboot:  0

=>

=> ping 128.224.155.1

Using FEC device

host 128.224.155.1 is alive

=>

View solution in original post

151 Views
timesyssupport
Senior Contributor II

Hi Zitao,

Because we are using the same U-Boot binary and you have matched your jumper configuration, it may be necessary to do the hardware mod to your TWR-SER module. You can find more information about this here:

https://community.freescale.com/thread/334492#comment-452442

Thanks,

Timesys Support

151 Views
zitaoliu
Contributor II

Hi Support team,

Thanks a lot, I use the image attachment and boot the board successfully, but still can't get network connection, the ethernet port even doesn't blink, the switch on the other side doesn't blink either.(I can make sure the cable works). I heard from our team that the old version of this board need solder a jump wire somewhere but they don't remember how to do it, but I'm not sure about this.

Is there anything else I can do?

IMG_1225.JPG

U-Boot 2013.07 (Oct 01 2015 - 00:13:47)

CPU:   Freescale Vybrid 600 family rev1.2 at 396 MHz

Reset cause: POR

Board: TWR-VF65GS10

DRAM:  128 MiB

WARNING: Caches not enabled

NAND:  256 MiB

MMC:   FSL_SDHC: 0

In:    serial

Out:   serial

Err:   serial

Net:   FEC

Hit any key to stop autoboot:  0

=> pri ipaddr

ipaddr=128.224.155.251

=> pri gatewayip

gatewayip=128.224.155.1

=> pri netmask

netmask=255.255.255.0

=> ping 128.224.155.1

FEC Waiting for PHY auto negotiation to complete......... TIMEOUT !

Using FEC device

ping failed; host 128.224.155.1 is not alive

=>

0 Kudos
151 Views
zitaoliu
Contributor II

Hi support team,

I've tried the attached image switches configurations but still can't get the network connection, I'm thinking if it's the uboot version, can you let me know where I can find the default version of uboot or can you send me the worked one you're using?

Thanks in advance,

Zitao

0 Kudos
151 Views
timesyssupport
Senior Contributor II

Hi Zitao,

I have attached the U-Boot image that I have used to verify network capabilities with. This was built using Timesys Factory build engine, for the standard Vybrid Tower machine.

Thanks,

Timesys Support

151 Views
timesyssupport
Senior Contributor II

Hi Zitao,

I verified that networking works with both U-Boot v2013.07 and Linux v3.13 for the Vybrid Tower using the TWR-SER module. Please find the attached image if you would like to verify your jumper/switch configuration.

Thanks,

Timesys Support

151 Views
karina_valencia
NXP Apps Support
NXP Apps Support

timesyssupport​ can you help here?

0 Kudos