Vybrid DMA Request from GPIO Input

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Vybrid DMA Request from GPIO Input

Jump to solution
1,594 Views
nathanb_
Contributor III

Hello All,

I'm currently trying to trigger a DMA request from an external GPIO input (PORT2[2]).

I can mux the GPIO input, and set the PCR->IRQC to 0xA and I get an interrupt generated no problem.

However, when I set the PCR->IRQC to 0x2, I never get a DMA request signal from DMA request source 41.

If I change the DMA request source to 24 (a flextimer I currently have running in DMA mode ), the DMA works correctly.

Does anyone know what's going on here?  Can anyone confirm that DMA requests from GPIO inputs correctly function?

Thanks.

Labels (6)
Tags (3)
0 Kudos
1 Solution
1,218 Views
alejandrolozan1
NXP Employee
NXP Employee

Hi,

It is not stated in the documentation but according to my tests it seems that the Table 3-2 is not correct.

The PORTA -PORTE should be PORT0-PORT4. With that modification the Table 3-31 matches and corresponds to the behavior you are facing.

As you can see PORT2[2] corresponds to PTD28 but at the end it belongs to PORT2 and DMA source 40 corresponds.

Best Regards,

Alejandro

View solution in original post

0 Kudos
3 Replies
1,218 Views
nathanb_
Contributor III

Oddly enough, I changed the request source to 40 and now it works.

However, PORT2[2] is PTD28.

Source 40 is PORT C in the manual.

Any clarity?

0 Kudos
1,219 Views
alejandrolozan1
NXP Employee
NXP Employee

Hi,

It is not stated in the documentation but according to my tests it seems that the Table 3-2 is not correct.

The PORTA -PORTE should be PORT0-PORT4. With that modification the Table 3-31 matches and corresponds to the behavior you are facing.

As you can see PORT2[2] corresponds to PTD28 but at the end it belongs to PORT2 and DMA source 40 corresponds.

Best Regards,

Alejandro

0 Kudos
1,218 Views
nathanb_
Contributor III

Thanks Alejandro,

This is what I was suspecting when I tried 40.

0 Kudos