[T1042 Ramdisk] Kernel panic - not syncing: No working init found. Try passing init= option to kernel.

cancel
Showing results for 
Search instead for 
Did you mean: 

[T1042 Ramdisk] Kernel panic - not syncing: No working init found. Try passing init= option to kernel.

Jump to solution
1,079 Views
yusufalti333
Contributor IV

Hello NXP,

I want to boot with ramdisk using commands below.

tftp 1000000 uImage--4.19-r0-t1042d4rdb-64b-20200217054545.bin
tftp 2000000 t1042d4rdb--4.19-r0-t1042d4rdb-64b-20200217054545.dtb
tftp 3000000 asd2.rootfs.ext2.gz.u-boot
bootm 1000000 3000000 2000000

I can successfully boot on bank0 with these commands. But when I switch to BANK 4 ( alternate bank ), It gives me error. Error logs are here;

Freeing unused kernel memory: 524K
This architecture does not have kernel memory protection.
Run /sbin/init as init process
EXT4-fs warning (device ram0): dx_probe:794: inode #3225: comm swapper/0: dx entry: limit 0 != root limit 125
EXT4-fs warning (device ram0): dx_probe:866: inode #3225: comm swapper/0: Corrupt directory, running e2fsck is recommended
Run /etc/init as init process
EXT4-fs warning (device ram0): dx_probe:794: inode #3361: comm swapper/0: dx entry: limit 0 != root limit 125
EXT4-fs warning (device ram0): dx_probe:866: inode #3361: comm swapper/0: Corrupt directory, running e2fsck is recommended
Run /bin/init as init process
Run /bin/sh as init process
Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/admin-guide/init.rst for guidance.
CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.19.26+gc0c2141 #1
Call Trace:
[c0000001f3107c70] [c000000000a810e4] .dump_stack+0xa8/0xec (unreliable)
[c0000001f3107d00] [c00000000004b580] .panic+0x12c/0x2e8
[c0000001f3107db0] [c000000000002464] .kernel_init+0x10c/0x128
[c0000001f3107e30] [c0000000000009f4] .ret_from_kernel_thread+0x58/0x64
Rebooting in 180 seconds..

I attached full logs from BANK0 booting and BANK4 booting. They both have same U-boot environment variables. I am suspecting that this is a QMan problem but I am unable to reach QMAN memory from U-boot console.

When I try to protect off QMan memory on flash

=> protect off 0xEFF10000 +$filesize  
Error: start address not on sector boundary

I had this error.

Any help ? Thanks.

0 Kudos
1 Solution
911 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Yusuf Altıparmak,

Please add "ramdisk_size=10000000" in bootargs.

In u-boot:

=>setenv bootargs "root=/dev/ram rw console=ttyS0,115200 ramdisk_size=10000000"

=>saveenv

Thanks,

Yiping

View solution in original post

0 Kudos
1 Reply
912 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Yusuf Altıparmak,

Please add "ramdisk_size=10000000" in bootargs.

In u-boot:

=>setenv bootargs "root=/dev/ram rw console=ttyS0,115200 ramdisk_size=10000000"

=>saveenv

Thanks,

Yiping

View solution in original post

0 Kudos