Build error in code warrior project

cancel
Showing results for 
Search instead for 
Did you mean: 

Build error in code warrior project

Jump to solution
3,788 Views
kanu__
Contributor III

hi ,

 

when i am trying to  build my project , am getting the following error.

 

any idea ?

 

 

process_begin: CreateProcess(NULL, echo "Regenerating dependency file: code/common/residu.d", ...) failed.
make (e=2): The system cannot find the file specified.


 

But the same project is successfully building in all other machines other than my machine.

 

Can you give ma rough idea about this kind of error ?

 

/renjith_g

Labels (1)
0 Kudos
1 Solution
510 Views
kanu__
Contributor III

 

hi all ,

 

me solved the above problem by the following way.

 

* The problem was due to the registry corruption(for path) in my machine for  my own user.

* Deleted that user and created a new one .

* Tried building it in the new user account and it was found successfull.

 

 

/Kanu__

View solution in original post

0 Kudos
8 Replies
510 Views
kanu__
Contributor III

 

hi ,

 

can anyone solve my new problem ?

 

https://community.freescale.com/thread/51806

 

 

/Kanu__

0 Kudos
510 Views
Irene
NXP Pro Support
NXP Pro Support

Which version of CodeWarrior tools are you using? Which processor are you using?  What operating system are you running on this machine?

 

Thanks,

Irene

 

 

0 Kudos
510 Views
kanu__
Contributor III

 

Please see the inline reply,

 

Which version of CodeWarrior tools are you using?

>> Code warrior version 10.0

 

Which processor are you using?

>>My host machine is Genuine Intel(R) CPU 2140 @1.60 GHz

 

 What operating system are you running on this machine?

>> I am having Microsoft Windows Xp professional version 2002 with service pack 2

 

/Kanu__

0 Kudos
510 Views
CrasyCat
Specialist III

Hello

 

Can you please try to do a Clean Project and than a Build Project?

 

I assume the CodeWarrior generated make files are pointing to some directory paths that do not exist on your system.

 

CrasyCat

0 Kudos
510 Views
kanu__
Contributor III

 

yes , i have done like that.

 

Now am suspecting my registry settings (especially the path settings , regedt32.exe) , because i've tried all other code warrior settings.

 

Also , i havn't got the expansion of the elb file format  yet.

 

/Kanu__

0 Kudos
510 Views
Irene
NXP Pro Support
NXP Pro Support

You did get a response for they elb format.  It is just the extension that is given to binary files that are produced by the Librarian. 

0 Kudos
510 Views
Irene
NXP Pro Support
NXP Pro Support

Is this a wizard project?  Is this a project that was imported from a previous version of CodeWarrior?

0 Kudos
511 Views
kanu__
Contributor III

 

hi all ,

 

me solved the above problem by the following way.

 

* The problem was due to the registry corruption(for path) in my machine for  my own user.

* Deleted that user and created a new one .

* Tried building it in the new user account and it was found successfull.

 

 

/Kanu__

View solution in original post

0 Kudos