APDU Commands via VCOM

cancel
Showing results for 
Search instead for 
Did you mean: 

APDU Commands via VCOM

197 Views
Contributor III

I am trying to send my APDU Commands via VCOM to the SE050. I am using Windows 10 OS and a FRDM-k64fd.

The Plug and Trust Examples using the SSS-API work fine but as soon as I want to send the APDU Commands I don't get any response from the Dev Board.

I am using the correct Baud Rate 155200 and can open the Port.

I'm sending the APDU Command: 01 00 00 04 80 04 00 20

which is and Example Command from the Plug and Trust Documentation.

Best regards

Labels (1)
0 Kudos
6 Replies

28 Views
NXP Employee
NXP Employee

Hello,

did you set DTR as described in simw-top/doc/appendix/vcom.html ?

DTR set is required for the VCOM firmware to receive the data.

Kind regards,

Michael

28 Views
Contributor III

Hello Michael,

thank you for the information.

Which tool would you recommend to quick test the APDU Commands with the SE050?

TeraTerm doesn't seem to have the functionality for sending data

Thanks alote

Best regards

Julian

0 Kudos

28 Views
NXP Employee
NXP Employee

Hello Julian,

On Windows e.g. HXTerm has to capability to set DTR using a GUI and being able to enter the commands in hex format. 

The Plug&Trust MW also contains the apdu-player example which builds on windows and linux:

Short documentation:

  • simw-top/doc/demos/apdu_player/Readme.html

Example Build folder on windows - needs to be built explicitly, project for build gets e.g. on windows created in this folder:

  • simw-top_build\se_x86\demos\apdu_player

Kind regards,

Michael

28 Views
Contributor III

Hello Michael,

I got myself HXTerm and sent some Commands in hex format to the SE050 but no response came back.

I got all the serial Configurations (Bautrate DTR etc.) right

I am using the SE050 Dev Board on the FRDM-k64fd: Any configurations needed?

The Plug and Trust examples with the Freedom Board work just fine

Maybe authentication for the SE is not plain? How can I check that?

Any specific Jumpers configurations needed? Before I started trying the APDU Commands I did the SE050 FRDM-k64fd Tutorial maybe some configuration there aren't suited for the APDU Commands

Thank you so much for your help

Best regards

Julian

0 Kudos

28 Views
NXP Employee
NXP Employee

Hello Julian,

some points to be sure:

- you put the firmware a7x_vcom-T1oI2C-frdmk64f-SE050x.bin on the K64F

- the SSS examples (and ssscli) executed on the Windows PC and connected over VCOM work (not executed directly on K64F)

- you opened the correct COM port - not the Debug-VCOM, but the VCOM provided by the host-USB port on K64F

When the windows-based examples work and you connect hterm to exactly this COM-port it will work like this, here the ATR is fetched using the vcom special command 00000000:

HTERM 1.png

HTERM 2.png

Even if e.g. platformSCP is switched on mandatory you will get at least an error code as response.

Kind regards,

Michael

28 Views
Contributor III

Hello Michael,

thanks you very much, that worked just like clock work!

I am getting the correct response from the SE050

For other users having the same problem, the "a7x_vcom-T1oI2C-frdmk64f-SE050x.bin" can be found in the plug&trust/simw-top/binaries folder

Kind regards,

Julian

0 Kudos