SCST in S32K146

cancel
Showing results for 
Search instead for 
Did you mean: 

SCST in S32K146

Jump to solution
517 Views
vishnukumar_n
Contributor II

Hello,

We are trying to integrate the SCST lib in our project which run on the S32K146 controller and the compiler used was GHS v2016.5.4.

After including the "-preprocess_assembly_files" in the cmake file, still we are getting the error as "The file "m4_scst_configuration.h" cannot open, error #......"

As per the manual "M4_S32K144_SCST_User_Manual", this SCST lib shall support the GHS compiler v2017.1.4 and v2017.5.4.

From the above statement, its is not possible to include other than those version in GHS? i.e. Not possible with the compiler v2016.5.4?

0 Kudos
1 Solution
492 Views
vishnukumar_n
Contributor II

Hello @frantisekdobes ,

Thanks for your support, with the option -I we build the lib without any issue.

Best regards,

Vishnu

View solution in original post

0 Kudos
2 Replies
493 Views
vishnukumar_n
Contributor II

Hello @frantisekdobes ,

Thanks for your support, with the option -I we build the lib without any issue.

Best regards,

Vishnu

0 Kudos
505 Views
frantisekdobes
NXP Employee
NXP Employee

Hello,

when the header file cannot be open this is usually caused by not adding -I assembler option to tell assembler where the include files shall be searched for. For example in my project I have to add the following assembler option:

-I./SCST/src/h

It is needed to update the path after -I option to point to the folder where the  m4_scst_configuration.h is located (in my case the path is ./SCST/src/h).
Regarding the compiler version, usually the SCST will work also with other versions of compiler but this was not checked nor tested. The only version which was tested is written in the SCST user manual (GHS compiler v2017.1.4 and v2017.5.4).

Best Regards,

Frantisek

0 Kudos