S32K344 Secure debug problem

cancel
Showing results for 
Search instead for 
Did you mean: 

S32K344 Secure debug problem

283 Views
sdfsdfdfdddd
Contributor I

i have meet a problem when i used the s32k344 chip,first time when i program the chip is ok,and program is running nomal,but when second program use PE and can not connect the targert,the error is blelow picture:fe6b2cf0ebcb862d181cfdc8fc0582f.png

 

 

IDE is S32DS3.4,and use PE download program,i am not sure why this issue have happened, may be the board chie entry the secure mode,how i change it to unsecure state?may be have some method?how solve this issue?

 

 

Tags (3)
0 Kudos
3 Replies

245 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Hi,

I just tested it and it works on my side. I used the same example, I programmed it several times by PE, tried to do power off-on and it still works.

It really shouldn't be related to the security. As I already mentioned, that's standard message when PE can't enter debug mode for some reasons. Was that brand new board? Did you check the ribbon cable between PE and the board? Can you program another board?

Regards,

Lukas

 

0 Kudos

260 Views
lukaszadrapa
NXP TechSupport
NXP TechSupport

Hi,

it doesn't sound like problem with the security, it's rather general message that the debugger can't establish the connection. I will try to check it on my board tomorrow. I will let you know my findings.

Regards,

Lukas

0 Kudos

87 Views
peter_yang
Contributor I

Hi Lukas,

have you solved this problem now?I have the same problem,when i use S32K344.

0 Kudos