LLCE LPSPI Support in Linux BSP33

cancel
Showing results for 
Search instead for 
Did you mean: 

LLCE LPSPI Support in Linux BSP33

Jump to solution
246 Views
yellapu_anishkh
Contributor III

Hello Team,

I am working on Board based on S32G, As part of project we have to enable LLCE SPI.

None of the reference boards(S32G-VNP-EVB and RDB3) are having this support.

I am using latest BSP, BSP33. In which i am able to see support for LLCE CAN support in Linux and in firmware support is there, with which we are able to validate CAN.

Before enabling LLCE LPSPI. Could you please answer below queries.

1. Any firmware bin changes required to enable LLCE LPSPI.

2. Linux driver is not there in BSP33, how LLCE communicates with S32G related to SPI transaction ?

Thank you for the support.

0 Kudos
1 Solution
218 Views
Daniel-Aguirre
NXP Employee
NXP Employee

Hi,

Below should be some comments over the questions you asked:

1) As told in LLCE User Manual, ppe_rx.bin is the file for core 1, in which LPSPI FW should be running.

2) At this moment, only QSPI and DSPI is being supported on the Linux kernel. As you are saying, no information is given for LLCE_LPSPI in the Linux User Manual. We cannot guarantee in the near future it will be supported, but stay tuned for any LLCE_LPSPI on the release notes for Linux BSP.

Please, let us know if this information is helpful or not.

View solution in original post

0 Kudos
5 Replies
151 Views
yellapu_anishkh
Contributor III

Hi Daniel,

Is the support present in AUTOSAR for LLCE LPSPI driver ?

Thank You,

 

0 Kudos
145 Views
Daniel-Aguirre
NXP Employee
NXP Employee

Hi,

At this moment, I'm not seeing any support regarding AUTOSAR for LLCE LPSPI, just the 3 main communication protocols (CAN, LIN and FlexRay).

Please, let us know if this information was helpful or not.

 

Tags (1)
0 Kudos
236 Views
Daniel-Aguirre
NXP Employee
NXP Employee

Hi,

Below should be some comments over the questions you asked:

1. The LLCE binaries loaded into the S32G should have the needed FW for core 1 (RXPPE) to be able to use the SPI firmware.

2. Regarding the communication between S32G and LLCE peripheral, inside the installation directory of LLCE (c:/nxp/S32G_LLCE_x_x_x) and following the folders "firmware/llce_interface/doc" will be the LLCE firmware user guide. The figure 1.14 [Page 35, LLCEfirmware, Rev 1.0.4] will give a high-level firmware architecture regarding the SPI firmware.

Please, let us know if this information was helpful or not.

0 Kudos
228 Views
yellapu_anishkh
Contributor III

Hi Daniel,

Thank you for the response.

1. SPI Firmware. I have downloaded LLCE firmware from NXP. Below binaries(dte.bin,frpe.bin,ppe_rx.bin,ppe_tx.bin) are present. As per below info ppe_rx.bin & ppe_tx.bin should support SPI firmware right ?

2.My focus area is Linux Operating System, where i have to enable LLCE SPI. In latest BSP, i am not seeing any support for LLCE SPI driver apart from LLCE CAN (drivers/net/can/llce/llce_can.c). Could you please confirm the support in Linux / Support is available only for AUTOSAR ?

 

0 Kudos
219 Views
Daniel-Aguirre
NXP Employee
NXP Employee

Hi,

Below should be some comments over the questions you asked:

1) As told in LLCE User Manual, ppe_rx.bin is the file for core 1, in which LPSPI FW should be running.

2) At this moment, only QSPI and DSPI is being supported on the Linux kernel. As you are saying, no information is given for LLCE_LPSPI in the Linux User Manual. We cannot guarantee in the near future it will be supported, but stay tuned for any LLCE_LPSPI on the release notes for Linux BSP.

Please, let us know if this information is helpful or not.

0 Kudos