library's setting in the projectinfo.xml doesn't work

cancel
Showing results for 
Search instead for 
Did you mean: 

library's setting in the projectinfo.xml doesn't work

285 Views
liuww_fnst
Contributor I

hello

I'm having a problem importing projectinfo.xml file into S32 Design Studio.

In the projectinfo.xml file, I tried to use libraries with the settings as showed in the following picture.

The library file is mpc.a.

XML.png

But after importing xml file , all configurations works but the library's configuration.

So I have to mannually add the library's name in order to compile the project successfully.

properties.png

I have also tried to export the projectinfo.xml from an existing project with the right library settings.

But there is no "-l:mpc.a"  in the exported XML file.

Is there anything wrong with my XML file?

Best regards!

Laura

0 Kudos
4 Replies

135 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

I try find out for what purpose can be projectinfo.xml used - but the only suitable use case which I found is transfer S32DS ARM project into IAR workbench. 

So, the question is, what you are trying to do with projectinfo.xml? If you like to import existing project into workspace - you can import it directly:
pastedImage_1.png

pastedImage_2.png

This will import project with all dependencies. 

Jiri 

0 Kudos

135 Views
liuww_fnst
Contributor I

Hi,

Thanks very much for your help!

With the projectinfo.xml, I just want to import the code generated by the matlab to S32 Design Studio without any mannual configuration.
The generated code only contains source files.So I tried to set the project properties using the projectinfo.xml.
If it works , after importing the projectinfo.xml, I can directly compile the project without any configuration.

Laura

0 Kudos

135 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

in this case importing/exporting library settings makes sense. I'll create ticket for that. Thank you for your report. 

Jiri

0 Kudos

135 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

it seems that export/import project settings doesn't include all options - including libraries and library paths. I'll do more investigation and if it is a bug, I'll create ticket for it. 

As a workaround you can add your libraries manually in project properties:

pastedImage_1.png 

Jiri

0 Kudos