error while dubbing: "ERROR loading to the device"

cancel
Showing results for 
Search instead for 
Did you mean: 

error while dubbing: "ERROR loading to the device"

1,484 Views
adrianwenger
Contributor III

Hi,

I wanted to debug code in S32DS.

After building DEBUG_RAM and starting the GDB PEMicro debugger,

the following error occured:

Debug - S32_ADsrcmain.png

What's the Problem here?

BR,

Adrian

Labels (2)
0 Kudos
5 Replies

281 Views
adrianwenger
Contributor III

Hi Stan,

- the mask is 0N47T.

- i used the GDB PEMicro section with the Interface OpenSDA Embedded Debug -USB Port

0 Kudos

281 Views
stanish
NXP Employee
NXP Employee

Hello Adrian,

Could you possibly try to update Pemicro plugin?

1) go to Help -> Install New Software

2) click on "Available Software Sites" and tick PEMicro:

pastedImage_1.png

3) select PEMicro site ARM update and proceed to install

pastedImage_2.png

reboot S32DS and try to create a new empty project for S32K144, build and debug.

Hope it helps.

Stan

0 Kudos

281 Views
adrianwenger
Contributor III

Hi Stan,

again I received an error while dubbing to target:

Debug - hellosrchello.png

Can you please help me again?

Regards,

Adrian

0 Kudos

281 Views
adrianwenger
Contributor III

Hi Stan,

it seems to work now with the PEmicor update.

Thanks!

0 Kudos

281 Views
stanish
NXP Employee
NXP Employee

Hello Adrian,

According to the screenshot it seems you run "Debug" configuration which loads the elf into internal flash memory instead of "Debug_RAM".

Can you please check which mask of S32K144 are you using (0N47T or 0N77P)?

Which debug interface/probe are you using (Segger Jlink, OpenSDA, Pemicro Multilink)?

This will help us to resolve the issue much faster.

Thank you!

Stan

0 Kudos