Project migration error from S32 Design Studio for S32 Platform v3.3 to v3.4

cancel
Showing results for 
Search instead for 
Did you mean: 

Project migration error from S32 Design Studio for S32 Platform v3.3 to v3.4

257 Views
DavidMunoz
Contributor II

Hi community, I hope you are doing pretty well, I have the following problem:

I have been working on a project with the IDE "S32 Design Studio for S32 Platform v3.3" with the SDK "S32SDK_S32K1XX_RTM_4.0.0" for a while but I have seen there is available a new version and I installed it and tried to import my current project but once imported the config tool is not working because the new IDE version "S32 Design Studio for S32 Platform v3.4" uses a new SDK "S32SDK_S32K1XX_RTM_4.0.1" then the following problem is displayed when trying to open config tool settings: 

"Error during opening configuration NAME.mex: Processor S32K1XX, S32sdk_s32k1xx_rtm_400 version is not supported by the current version of tool".


Do you have any solution to migrate a project successfully and migrate the SDK from rtm 400 to 401?

 

Regards,

Labels (2)
0 Kudos
1 Reply

190 Views
jiri_kral
NXP Employee
NXP Employee

Hi, 

did you tried migration tool? This tool should be able migrate older projects into new environment: 

jiri_kral_0-1623237430345.png

 

jiri_kral_1-1623237495571.png

 

Jiri

 

 

0 Kudos