Program "-E" not found in PATH

cancel
Showing results for 
Search instead for 
Did you mean: 

Program "-E" not found in PATH

846 Views
Contributor II

I uninstalled and then installed a newer version of S32DS, and I am not able to debug the project.

I also have this message:

Orphaned configuration. No base extension cfg exists for com.freescale.s32ds.cross.gnu.arm.cortexm.exe.debug.1507198855

SW version: 2018.R1

I am trying to run the BCC_S32K144_MC33771_SPI_FreeMASTER example.

Capture.JPG

Can anyone help?

Thanks,

Moe

Tags (1)
7 Replies

94 Views
NXP Employee
NXP Employee

The message indicates that you have your project configured for a toolchain (or toolchain integration) which does not exist any more.

Does it happen as well for a new project or is this an existing project?

I hope this helps,

Erich

94 Views
Contributor II

This is an existing project.

I tried the following but didn't solve the problem:
1 - Deleted the project (and all its contents on disk).

2- Downloaded the project again from NXP website

3- Imported the project as a new project.

This didn't solve the problem tho!

Capture.JPG

0 Kudos

94 Views
NXP Employee
NXP Employee

Does it happen as well for a new project you create with the wizard?

That 'orphaned' message says that you have a project using the build plugin com.freescale.s32ds.cross.gnu.cortexm.... but you don't have that plugin installed.

0 Kudos

94 Views
Contributor I

Hi, Erich. I got the same problem when I installed S32DS v3.3 before uninstalling v2.0.

As you said, the build plugin is missing. So is there any way to install the specific plugin? How to search for it?

Thx.

0 Kudos

94 Views
NXP Employee
NXP Employee

Hi, 

I just tried this demo in S32DS ARM v2018.R1 with all updates - and it works okay for me. Did you installed latest updates? 

Jiri

0 Kudos

94 Views
Contributor I

Yes, I installed the latest updates.

But I did not run this demo, but a project my company made before.

I found that it worked okay when I deleted the project and recovered it from a backup zip.

So I guess the error was because S32DS v3.3 damaged the project files generated by S32DS v2.0.

0 Kudos

94 Views
NXP Employee
NXP Employee

Hi, 

If you tried open it with S32DS v3.3 - it is possible. This version is for different platform - here you can find more details about S32DS versions: S32 Design Studio - Releases & Updates  .

Latest version for ARM target is https://community.nxp.com/docs/DOC-345517 . But this version is not supporting older SDK versions. 

Jiri 

0 Kudos