Problems using PEmicro USB Multilink Universal

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems using PEmicro USB Multilink Universal

1,437 Views
Joao_Roscoe
Contributor III

I'm having trouble trying to debug my app in S32K144EVB with S32DS for ARM and a PEmicro Multilink Universal - the blue box.

I have already installed PEmicro software, as administrator, and I can see two devices under "Jungo" group - one is "pemicrowindrvr" and the other is a "USB Multilink 2.0". However, in S32DS's Debug configuration, when I select "USB Multilink" for interface, in the "Debug" tab, S32DS won't show anything in the "Port" selection combo, even after clicking the "Refresh" button. 

I did tried proceeding anyway, but S32D just stopped, displaying a message that asked to review the Debug configuration.

I'm using Windows 10, with just downloaded drivers, and up-to-date S32DS. For now, my target system is a S32K144EVB.

What am I missing here?

Best regards,

Joao

Labels (1)
0 Kudos
1 Reply

734 Views
stanish
NXP Employee
NXP Employee

Hi Joao,

I assume you have installed the versions below

S32 Design Studio for ARM 2018.R1 (Windows/Linux) released! 

S32 Design Studio for ARM 2018.R1 - Update 8 available 

Also I assume you installed the latest pemicro drivers (PE Hardware Interface Drivers)

http://www.pemicro.com/downloads/download_file.cfm?download_id=53 

According to your description it seems it worked fine before and then suddenly S32DS stopped displaying Multilink probe.

Are both LEDs (Blue+Yellow) On when you are connected to the target board?

Could you possibly try to use the probe on different computer?

Have you installed in the mean time some other software on your computer (e.g. Xilinx )?

P&E Drivers for Windows utilize the 3rd party service Jungo WinDriver to enable USB support under windows XP/7/8.x/10. Xilinx also uses WinDriver for their driver packages, but older versions. Starting with the P&E Driver package 11.7, a conflict between P&E Drivers and software IDES that rely on older Jungo driver packages might occur.

Hope it helps.

Stan

0 Kudos