MPC5744P s32dc and AMMCLIB

cancel
Showing results for 
Search instead for 
Did you mean: 

MPC5744P s32dc and AMMCLIB

1,314 Views
dyc09052110
Contributor I

HI:

I'm programming MPC5744P by S32DS.There is a problem about MPC574xP_AMMCLIB_V1.1.7. When i build my project,It reminds me "C:/Freescale/AMMCLIB/MPC574xP_AMMCLIB_v1.1.7/include/SWLIBS_Defines.h lsp.h:No such file or directory".I also can not find the lsp.h in my computer.

Great thanks!

YongChao Ding

0 Kudos
4 Replies

793 Views
stanish
NXP Employee
NXP Employee

Hi,

Indeed lsp.h is missing in S32DS for Power v1.1 this is a known issue.

This will be fixed in coming release S32DS for Power v1.2 that should be released by the end of March 2017.

You can use attached file in the meantime.

please copy the file into both EWL include folder:

<S32_Power_v1.1>\S32DS\e200_ewl2\EWL_C\include\pa\lsp.h

and NewLib include folder:

<S32_Power_v1.1>\Cross_Tools\powerpc-eabivle-4_9\lib\gcc\powerpc-eabivle\4.9.2\include\lsp.h

Hope it helps.

Stan

0 Kudos

793 Views
embedded_eng
Contributor I

Try to setup PATH variables in a correct way.

0 Kudos

793 Views
dyc09052110
Contributor I

Hi:

I have already installed the MPC574xP_AMMCLIB_v1.1.7 according to its documentation.I also have set up the path as described in the documentation correctly,but it still prompts this error.In my opinion,even if my path is set incorrectly, but after I installed S32DS and MPC574xP_AMMCLIB_v1.1.7, lsp.h header file should be in my computer inside. But I did not find this file in my computer.How should I solve this problem?

Great thanks!

YongChao Ding

0 Kudos

793 Views
embedded_eng
Contributor I

I'm not familliar with AMMCLIB. But, I know that you can't compile your code if you included a PATH for a variable (file) which doesn't exist.

Try to understand if lsp.h is really needed, if not, exclude it from build, if yes, you should find it somewhere else. Also, make sure that AMMCLIB is not unpacked your lsp.h somewhere else, or MAYBE lsp.h can be found in older versions of AMMCLIB (maybe you should first install older version, that update).

Regards.

0 Kudos