bitbake U-Boot error with bison_3.8.2.bb: Dependency loop #1 found

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

bitbake U-Boot error with bison_3.8.2.bb: Dependency loop #1 found

303 Views
amohan
Contributor I

With FSL-LS1021AIOT-SDK V1.8, we are trying to build u-boot using bitbake (v 1.22.0) on Ubuntu-22.04 however we are getting a dependency loop error. Would anyone know how to resolve this? I had to update the version of recipes-devtools/bison to bison_3.8.2.bb. And because of which I am getting the following error:

 

 

Build Configuration:
BB_VERSION        = "1.22.0"
BUILD_SYS         = "x86_64-linux"
NATIVELSBSTRING   = "Ubuntu-22.04"
TARGET_SYS        = "arm-fsl-linux-gnueabi"
MACHINE           = "ls1021aiot"
DISTRO            = "fsl-networking"
DISTRO_VERSION    = "QorIQ-SDK-V1.8"
TUNE_FEATURES     = "armv7a vfp neon callconvention-hard cortexa7"
TARGET_FPU        = "vfp-neon"
meta
meta-yocto
meta-yocto-bsp
meta-rds
meta-fsl-arm
meta-fsl-networking
meta-fsl-toolchain
meta-virtualization
meta-oe
meta-networking
meta-perl
toolchain-layer
meta-java
meta-linaro-toolchain
meta-security     = "feature/jpc/jenkins:073d500a2f332da0d339f635acf98a3a69ed1e25"

NOTE: Preparing runqueue
ERROR: Unbuildable tasks were found.
These are usually caused by circular dependencies and any circular dependency chains found will be printed below. Increase the debug level to see a list of unbuildable tasks.

Identifying dependency loops (this may take a short while)...

ERROR:
Dependency loop #1 found:
  Task 187 (virtual:native:/home/trilliant/tmpDev/arnav_dev/fsl-ls1021aiot-sdk/poky/meta/recipes-devtools/bison/bison_3.8.2.bb, do_install) (dependent Tasks ['bison, do_compile'])
  Task 188 (virtual:native:/home/trilliant/tmpDev/arnav_dev/fsl-ls1021aiot-sdk/poky/meta/recipes-devtools/bison/bison_3.8.2.bb, do_populate_sysroot) (dependent Tasks ['bison, do_install'])
  Task 190 (virtual:native:/home/trilliant/tmpDev/arnav_dev/fsl-ls1021aiot-sdk/poky/meta/recipes-devtools/bison/bison_3.8.2.bb, do_configure) (dependent Tasks ['autoconf, do_populate_sysroot', 'automake, do_populate_sysroot', 'gettext-minimal-native, do_populate_sysroot', 'libtool-native, do_populate_sysroot', 'bison, do_patch', 'bison, do_populate_sysroot', 'gnu-config, do_populate_sysroot', 'flex, do_populate_sysroot'])
  Task 191 (virtual:native:/home/trilliant/tmpDev/arnav_dev/fsl-ls1021aiot-sdk/poky/meta/recipes-devtools/bison/bison_3.8.2.bb, do_compile) (dependent Tasks ['bison, do_configure'])

 

 

0 Kudos
3 Replies

220 Views
amohan
Contributor I

Is that the latest version Ubuntu supported by FSL-LS1021AIOT-SDK V1.8? 

Can we use any Ubuntu version after 14.04?

0 Kudos

218 Views
yipingwang
NXP TechSupport
NXP TechSupport

That's the latest version Ubuntu. Please use Ubuntu 14.04.

0 Kudos

243 Views
yipingwang
NXP TechSupport
NXP TechSupport

Please use Ubuntu 14.04

0 Kudos