LSDK19.09 for linux 5.4

cancel
Showing results for 
Search instead for 
Did you mean: 

LSDK19.09 for linux 5.4

Jump to solution
620 Views
kai_wu
Contributor III

Hi,

I am trying to compile the linux5.4 from LSDK19.09.

I tried to use command.

                     flex-builder -c linux:linux:v5.4 -a arm64    

But I got an error about fsl-ls1043a-rdb-sdk.dtb,  see below. 

make[3]: Entering directory '/home/kaiw/fijowave/fijosat-base/sdk/flexbuild_lsdk1909_update_221019/build/linux/linux/arm64/LS/output/v5.2'
Using /home/kaiw/fijowave/fijosat-base/sdk/flexbuild_lsdk1909_update_221019/packages/linux/linux as source for kernel
make[4]: *** No rule to make target 'arch/arm64/boot/dts/freescale/fsl-ls1043a-rdb-sdk.dtb'. Stop.

I found the targets are defined in flexbuild_lsdk1909_update_221019/packages/linux/Makefile, because I am building the Linux kernel for ls1012a processor, so I commented out the UEFI_DTB_LIST in the Makefile.    

UEFI_DTB_LIST = freescale/fsl-ls1043a-rdb-sdk.dtb freescale/fsl-ls1046a-rdb-sdk.dtb freescale/fsl-ls2088a-rdb.dtb freescale/fsl-lx2160a-rdb.dtb

Then I tried to run the flex-builder command again, the build process goes further, but I met the problem with cryptodev_linux, see below.          

ERROR: "crypto_givcipher_type" [/home/kaiw/fijowave/fijosat-base/sdk/flexbuild_lsdk1909_update_221019/packages/linux/cryptodev_linux/cryptodev.ko] undefined!
/home/kaiw/fijowave/fijosat-base/sdk/flexbuild_lsdk1909_update_221019/packages/linux/linux/scripts/Makefile.modpost:91: recipe for target '__modpost' failed

Any help will be much appreciated. Thank you.

Labels (1)
0 Kudos
1 Solution
400 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Kai Wu ,

In file configs/build_lsdk.cfg, please disable options CONFIG_KERL_GPU_MODULE

and CONFIG_KERL_CRYPTODEV_LINUX, please refer to the following, then rebuild Linux Kernel.

#CONFIG_KERL_GPU_MODULE=y
#CONFIG_KERL_CRYPTODEV_LINUX=y

Thanks,

Yiping

View solution in original post

0 Kudos
2 Replies
401 Views
yipingwang
NXP TechSupport
NXP TechSupport

Hello Kai Wu ,

In file configs/build_lsdk.cfg, please disable options CONFIG_KERL_GPU_MODULE

and CONFIG_KERL_CRYPTODEV_LINUX, please refer to the following, then rebuild Linux Kernel.

#CONFIG_KERL_GPU_MODULE=y
#CONFIG_KERL_CRYPTODEV_LINUX=y

Thanks,

Yiping

View solution in original post

0 Kudos
400 Views
kai_wu
Contributor III

Thanks, Yiping, it works.

0 Kudos