Problems with CW10.6 or Erich Styger updated PE components

cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with CW10.6 or Erich Styger updated PE components

Jump to solution
355 Views
tomasmickus
Contributor II

I have reinstalled Windows also with CW and Erich Styger component library both which were downloaded and installed on March 22, could someone say if Codewarrior version changed since then? Because i can't set two values in clock rate at SM1_SPIMaster component any more, clock rate parameter detail says "375kHz; 1 additional value in list:12MHz", before change it was "2 values in list", also SD card work only on 375kHz, it looks it can't accepts second value any more. It's frustrating, when something that worked, works no more. FRDM - KL25Z board.Even Erich Styger example with fatfs shows the same and don't work the same.No matter what frequency i choose for Mode1 in SM1_SPIMaster when i reopen it it writes the same numbers as Mode0.

0 Kudos
1 Solution
194 Views
BlackNight
NXP Employee
NXP Employee

Hi Tomas,

I have now checked this in 10.6. The thing is that the project works, but as soon as I check the SPI clock values, the original 375kHz;12MHz ones get listed as 375kHz;375MHz (!!!), and changing/modifying the value get it changed to 375 MHz (which is wrong and correctly flagged as an error) :-(. I have submitted a ticket, and for now I do not have a workaround (except that you do not touch the values, as code generation seems fine for me).

Erich

View solution in original post

0 Kudos
4 Replies
195 Views
BlackNight
NXP Employee
NXP Employee

Hi Tomas,

I have now checked this in 10.6. The thing is that the project works, but as soon as I check the SPI clock values, the original 375kHz;12MHz ones get listed as 375kHz;375MHz (!!!), and changing/modifying the value get it changed to 375 MHz (which is wrong and correctly flagged as an error) :-(. I have submitted a ticket, and for now I do not have a workaround (except that you do not touch the values, as code generation seems fine for me).

Erich

0 Kudos
194 Views
tomasmickus
Contributor II

Exactly. I checked with oscilloscope SPI clock frequency when writing to SD card data, it's 375kHz, it's representing Mode0 setting. So conclusion, now SD card can work only on initialize frequency, which is horrible for writing bunch of data, i measured to write 600B now takes 80ms. And i hope for update of cw10.6 or the best way if i could find where to download cw10.5 :smileyconfused:

0 Kudos
194 Views
BlackNight
NXP Employee
NXP Employee

The 10.5 is still on the web for download:

http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=CW-MCU10&fpsp=1&tab=Design_Tools_Tab

I suggest you get that version. No need to uninstall the 10.6 (keep it just in case): simply download the 10.5 and install it (into a different folder than 10.6 of course).

Let me know if you need any help with this.

Erich

194 Views
tomasmickus
Contributor II

Thank you very much, i was looking for that but couldn't find. You make good libraries, tutorials, i think PE is best choice stepping from arduino to cortex world :smileyhappy:

0 Kudos