KITFS85FRDMEVM (FS8530) Turns Itself Off After 5 Seconds

cancel
Showing results for 
Search instead for 
Did you mean: 

KITFS85FRDMEVM (FS8530) Turns Itself Off After 5 Seconds

Jump to solution
1,220 Views
ftD3v
Contributor II

Hey,

We're using FS8530 in our custom hardwares and we're using KITFS85FRDMEVM kit for testing purposes

I've burned the OTP with the file attached (buck1_1.2---buck3_3.3.txt). It basically sets buck1 to 1.2V, buck3 to 3.3V, and closes the init stage. The problem is that, if I run the system by Set5vDbg -> PowerOn12v -> TurnOnWake1 -> Unplug5vDbgJumper, it stays alive, buck1 and buck3 run forever. But if I run the system by Unplug5vDbg -> PowerOn12v -> TurnOnWake1, the system turns itself off after about 5 seconds. I took a video of this: https://youtu.be/Qd6tl6yvZ34

The second way is how it should be working on our custom board. What is the problem here ? How can I solve the problem ?

Thanks in advance.
Regards.

Furkan Tokaç
Electronics & Software Department
Labels (1)
0 Kudos
1 Solution
1,170 Views
ftD3v
Contributor II

Hey Tomas,

We've successfully run the system by disabling the Watchdog manually. I'll tell what we have done, it may be helpful to people. To disable Watchdog;

  1. Goal: VPRE 5.0V, Buck1 1.2V, Buck3 3.3V
  2. Download OTP file that I've shared from the previous message.
  3. Change the line SET_REG:FS85:FS_OTP:FS_MIRRORDATA:0x0040 to SET_REG:FS85:FS_OTP:FS_MIRRORDATA:0x00C0
  4. Burn the OTP file.

This is OK for the first step but we need to go forward now. If I need any other question, I'll create a new question.

Thanks for your interest!

Regards,

Furkan Tokaç
Electronics & Software Department

View solution in original post

0 Kudos
3 Replies
1,188 Views
TomasVaverka
NXP TechSupport
NXP TechSupport

Hello Furkan,

Could you please share a config file, like the one attached, using the Excel file attached?

I presume the reason is you did not disable the watchdog by OTP.

If you power-up without debug mode (like the second scenario), it is needed to close the Init phase (once RESETB is released high) within 256ms window, and then to refresh watchdog, otherwise device shutdowns.

Also things to consider:

- Are you sure the OTP is burned? When you first power-up in the Debug mode, you don’t write any command right?

- Check Watchdog config in OTP.

Hope this helps.

Best regards,

Tomas

0 Kudos
1,171 Views
ftD3v
Contributor II

Hey Tomas,

We've successfully run the system by disabling the Watchdog manually. I'll tell what we have done, it may be helpful to people. To disable Watchdog;

  1. Goal: VPRE 5.0V, Buck1 1.2V, Buck3 3.3V
  2. Download OTP file that I've shared from the previous message.
  3. Change the line SET_REG:FS85:FS_OTP:FS_MIRRORDATA:0x0040 to SET_REG:FS85:FS_OTP:FS_MIRRORDATA:0x00C0
  4. Burn the OTP file.

This is OK for the first step but we need to go forward now. If I need any other question, I'll create a new question.

Thanks for your interest!

Regards,

Furkan Tokaç
Electronics & Software Department
0 Kudos
1,179 Views
ftD3v
Contributor II

Hey Tomas,

The Excel file and its OTP file are attached. I've created the OTP file by

1. Clicking the "Write_OTP_File_GUI" button in the Excel file and getting the OTP file (buck1_1.2--buck3_3.3.txt).
2. Editing the last part, called "// FS85_Release_FS0b" to the OTP file for a successful initialization ending.

And then, I've burned the OTP file (buck1_1.2--buck3_3.3.txt) to the chip. I'm sure that it is burned without any problem since I get correct voltage outputs after burning. (we also have KITFS85SKTEVM kit, what we're doing now is that we're configuring the chip and putting it to our hardware design, but I've asked the question on KITFS85FRDMEVM to make it easy to understand, behaviours are the same for both cards.)

The thing is that, in the Excel file, it is not allowing me to change the "WD_DIS" option.

 

If you power-up without debug mode (like the second scenario), it is needed to close the Init phase (once RESETB is released high) within 256ms window, and then to refresh watchdog, otherwise device shutdowns.

Yes I want to power-up without debug mode, so what should I add to the OTP file to be able to successfully close the init phase ?

 

- Are you sure the OTP is burned? When you first power-up in the Debug mode, you don’t write any command right?

I don't write any extra command. It works even without USB connection, with only 12V power supply.

 

- Check Watchdog config in OTP.

It is just OK if we can successfully run it without watchdog since we need to test our hardware. Our current goal is having a FS8530 that gives the required voltage outputs (buck1 1.2V, buck2 3.3V, vpre 5.0V) after the wake-up signal, without any external communication. The detailed work will be done after this stage, including all the functional safety, iso26262 topics etc.

Thanks for your interest!

Regards,

Furkan Tokaç
Electronics & Software Department
0 Kudos