SRA application on p2041rdb

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

SRA application on p2041rdb

Jump to solution
797 Views
norabjorklund
Contributor II

Hi,

I am trying to run the sra application on p2041rdb, but cannot get it working well. I compared it by running the same application and commands on t4240qds. And I was wondering what the problem could be.

When I start up the application I receive the following message:

sra: dma_usmem_init(): dma_mem_create(): Invalid argument

sra: dma_pool_init(): DMA pool: Invalid argument

I ran the first example in the SRA guide [1] And at the second step I received a segfault:

sra> sra -attr port1 win_attr 1 nwrite nread

sra> sra -op port1 1 0 0 s 0x100000

sra[1665]: unhandled signal 11 at 00000000 nip 0fec49d0 lr 100022f4 code 30001

Segmentation fault

(Running the same steps on t4240qds works well)

I am running fsl-image-core with the extra kernel configurations mentioned in th UG.

Best regards,

Nora

-----------

[1] Submit Form

Labels (1)
Tags (3)
0 Kudos
Reply
1 Solution
539 Views
norabjorklund
Contributor II

The usdpaa_mem boot argument was the error, I had in accordance with the SRA UG given usdpaa_mem=512M however for p2041 and p3041 this is too large. The sra application worked properly with usdpaa_mem=64M.

View solution in original post

0 Kudos
Reply
1 Reply
540 Views
norabjorklund
Contributor II

The usdpaa_mem boot argument was the error, I had in accordance with the SRA UG given usdpaa_mem=512M however for p2041 and p3041 this is too large. The sra application worked properly with usdpaa_mem=64M.

0 Kudos
Reply