PMSM Motor Parameter Measurement -> JScript Error?

cancel
Showing results for 
Search instead for 
Did you mean: 

PMSM Motor Parameter Measurement -> JScript Error?

197 Views
Contributor II

cliHello,

  I am in the process of doing some fine tuning on some custom hardware and motors.  Sometime back I had used the Motor parameters measurment utility in the MCAT pmsm_ref_sol.pmp application from the MCRSP_PMSP_V1.2 installation.  For some reason now every time I try to use this utility I get the following error when I click Measure...?

Any idea of how to fix this?  This was a very useful utility to measure custom motor parameters quickly and easily.

pastedImage_2.png

Regards,

Frank

0 Kudos
5 Replies

78 Views
NXP TechSupport
NXP TechSupport

Hi Frank Roberts ,

    Could you please also give me MCRSP_PMSP_V1.2 download link in the nxp.com?

    Do you mean, it works in the previous time, but for some reason, it meets the script issue, right?

    Do you try to uninstall it, and install it again, any improvement?

Wish it helps you!

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

78 Views
Contributor II

Hello Kerry I have not tried to uninstall this as of yet as that seemed liked kind of a harsh/sledgehammer method considering everything else in the Freemaster GUI is working as expected.  YES this Motor Identification functionality worked no less than about a month or so ago and now it does not work as I have shown above.

My question is whether someone can tell me if it requires a specific version of Java to be installed?  I.E. - I know my PC updated Java within the last month to the latest Java version.

 You can find the link by searching for MCRSP_PMSM on the NXP website.  There is an older version V1.1.2 and the newer version that I am using V1.2 with the link below...

https://www.nxp.com/downloads/en/reference-applications/MCRSP_PMSM_V1.2.0.exe 

Regards,

Frank

0 Kudos

78 Views
NXP TechSupport
NXP TechSupport

Hi Frank Roberts,

  I checked the MCRSP_PMSM v1.2.0 release note, which freemaster version you are using?

2 Development tools
The NXP MCRSP_PMSM v1.2.0 was compiled and tested with these development tools:
 IAR Embedded Workbench IDE v7.70.2
 Kinetis Design Studio IDE v3.2
 ARM-MDK - Keil® μVision® version 5.21
For the application capabilities demonstration, the following tool is required to be installed:
FreeMASTER Run-Time Debugging Tool 2.0.2.4

 

My freemaster version is v2.5, I really also reproduce your issue:

pastedImage_2.png

Please help to check your freemaster version, maybe it is related to the freemaster version.

Then I will check the internal side.

BTW,do  you try to click yes? it seems after click yes, the measure still can be clicked.

Wish it helps you!

Kerry

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos

78 Views
Contributor II

Hello Kerry,

  I am using FreeMASTER Version 2.0.9.  I think we are missing the point that this all worked fine no less than ~3-4 weeks ago and the rest of the pmsm_ref_sol.pmp is still working fine just this Motor Identification tab is not working.  I have not changed/updated my FreeMASTER version since this was working sometime back...let me try to uninstall and re-install and see what happens.  It still seems highly suspicious that my computer recently went through a Java Installation update and this stopped working in which it certainly appears to be a Java Script.

Regards,

Frank

0 Kudos

78 Views
NXP TechSupport
NXP TechSupport

Hi Frank Roberts

   Thanks for your effort.

    Please try to reinstall it again, whether it has any improvement.

    If you have any other PC, you also can try it.

    Any updated information, please kindly let me know.

    If still have problems, I will help you to find some internal engineer who is in charge of this software.

 

-------------------------------------------------------------------------------
Note:
- If this post answers your question, please click the "Mark Correct" button. Thank you!

 

- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.
-------------------------------------------------------------------------------

0 Kudos