problems with security_webserver project

取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
已解决

problems with security_webserver project

跳至解决方案
662 次查看
feraro
Contributor IV

Hello.

I'm testing the demo "security_webserver" and I have the following problem, if DEMOCFG_ENABLE_SNTP = 1 and DEMOCFG_ENABLE_DHCP = 1, it works fine, but if DEMOCFG_ENABLE_SNTP = 1 and DEMOCFG_ENABLE_DHCP = 0, the function "RTCS_resolve_ip_address ()" returns me a 0. Anyone know the cause?.

I need to use this function with DHCP to OFF.

I´m working with MQX3.7


Thanks in advance.

标签 (1)
0 项奖励
1 解答
440 次查看
Luis_Garabo
NXP TechSupport
NXP TechSupport

Hi Fernando,

Are you sure you are assigning a static IP address to the board that is in the same network where it is connected?

You can set the IP in the file Security.h. Look for the ENET_IPADDR define:

#define ENET_IPADDR  IPADDR(169,254,3,3)

If you are using the IP 192.168.1.5, for instance then you have to change to:

#define ENET_IPADDR  IPADDR(192,168,1,5)

Hope this helps,

Regards,

-Garabo

在原帖中查看解决方案

0 项奖励
1 回复
441 次查看
Luis_Garabo
NXP TechSupport
NXP TechSupport

Hi Fernando,

Are you sure you are assigning a static IP address to the board that is in the same network where it is connected?

You can set the IP in the file Security.h. Look for the ENET_IPADDR define:

#define ENET_IPADDR  IPADDR(169,254,3,3)

If you are using the IP 192.168.1.5, for instance then you have to change to:

#define ENET_IPADDR  IPADDR(192,168,1,5)

Hope this helps,

Regards,

-Garabo

0 项奖励