k64f hallo example no com port found

cancel
Showing results for 
Search instead for 
Did you mean: 

k64f hallo example no com port found

Jump to solution
338 Views
niklasroth
Contributor III

Hi

I have a frdm-k64f board. I just wanted to try out the mqx hello world example. I drag and droped the hello_frdmk64f.wsd into my cw10.6 workspace. I pluged in the usb connector into the K64F USB connector, over which the board is supplied and is communicating.

After compiling that project (debug mode) pressing the build (hammer), I press "Debug" to download and start the applicaiton. Then I open a Termite to connect to a com-port but unfortunatelly no com-port appears!? What did I do wrong? Do I need to install a special driver usb to serial driver?

My system:

Windows 7

cw10.6

mqx4.2

greets nik

0 Kudos
1 Solution
116 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Niklas,

Please connect the USB to  OpenSDA (J26 pin ) port on FRDM-K64 , and configure the terminal to

115200 baud, 8 data bits, 1 stop bit, no parity

If it still can not work , please tell me which version of MQX  。

Hope it helps



-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

Have a great day,
Alice

View solution in original post

2 Replies
117 Views
Alice_Yang
NXP TechSupport
NXP TechSupport

Hello Niklas,

Please connect the USB to  OpenSDA (J26 pin ) port on FRDM-K64 , and configure the terminal to

115200 baud, 8 data bits, 1 stop bit, no parity

If it still can not work , please tell me which version of MQX  。

Hope it helps



-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

Have a great day,
Alice

View solution in original post

116 Views
niklasroth
Contributor III

I tried that before but it didn't work. Then I changed the serial monitor software and it worked. "Termite" didn't received any messages but "putty" worked pretty well :-)

Thx for helping!!

0 Kudos