httpsrv example on FRDM-K64F

cancel
Showing results for 
Search instead for 
Did you mean: 

httpsrv example on FRDM-K64F

Jump to solution
633 Views
mittymcdoogle
Contributor III

Hi,

I've tried running the httpsrv example code found in the MQX 4.2 package on my K64 freedom board. However, when I try to use the command prompt to ping the board, I fail to receive any response.

What can I do to get this demo working on my board?

Thanks,

Mitty

0 Kudos
1 Solution
232 Views
DavidS
NXP Employee
NXP Employee

Hi Mitty,

Try the following to cause your frdm-k64f Freedom board to do a DHCP:

Starting HTTP server No.0 on IP 192.168.1.202, port 80...[OK]

Shell (build: Jul  6 2015)

Copyright (c) 2013 Freescale Semiconductor;

shell>

shell> ipconfig dhcp

Bind via dhcp successful.

shell>

shell> ipconfig

Eth#     : 0

Link     : on

MTU      : 1500

MAC      : 00:00:5e:a8:01:ca

IP4      : 10.0.1.187 Type: DHCPNOAUTO

IP4 Mask : 255.255.255.0

IP4 Gate : 10.0.1.1

IP4 DNS  : 10.0.1.1

IP6      : DISABLED

Link status task stopped

shell>

shell> ping 10.0.1.1

Pinging 10.0.1.1:

Press [q] to cancel.

Reply from [10.0.1.1]: time=8ms

Reply from [10.0.1.1]: time=3ms

Reply from [10.0.1.1]: time=4ms

Reply from [10.0.1.1]: time=4ms

shell>

Regards,

David

View solution in original post

9 Replies
232 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi Mitty:

I think you can check the jumper settings in your board. Please refer to section 9.3 FRDM-K64F in MQX_Getting_Started.pdf.


Have a nice day,
Daniel

0 Kudos
232 Views
mittymcdoogle
Contributor III

Hi Daniel,

I don't see any jumper settings for Ethernet - were you just asking that I check my jumpers versus the default jumper configuration?

Thanks,

Mitty

0 Kudos
232 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi Mitty

Yes, the default jumper configurations is OK

I can run this demo in FRDM-K64 without problems.   please see the following picture, 192.168.1.10 is my PC's IP

pastedImage_0.png

0 Kudos
232 Views
mittymcdoogle
Contributor III

Hi Daniel,

I have checked all of my jumpers to make sure that they are set to the default position. I am still unable to ping the board or see the board through my router.

0 Kudos
233 Views
DavidS
NXP Employee
NXP Employee

Hi Mitty,

Try the following to cause your frdm-k64f Freedom board to do a DHCP:

Starting HTTP server No.0 on IP 192.168.1.202, port 80...[OK]

Shell (build: Jul  6 2015)

Copyright (c) 2013 Freescale Semiconductor;

shell>

shell> ipconfig dhcp

Bind via dhcp successful.

shell>

shell> ipconfig

Eth#     : 0

Link     : on

MTU      : 1500

MAC      : 00:00:5e:a8:01:ca

IP4      : 10.0.1.187 Type: DHCPNOAUTO

IP4 Mask : 255.255.255.0

IP4 Gate : 10.0.1.1

IP4 DNS  : 10.0.1.1

IP6      : DISABLED

Link status task stopped

shell>

shell> ping 10.0.1.1

Pinging 10.0.1.1:

Press [q] to cancel.

Reply from [10.0.1.1]: time=8ms

Reply from [10.0.1.1]: time=3ms

Reply from [10.0.1.1]: time=4ms

Reply from [10.0.1.1]: time=4ms

shell>

Regards,

David

View solution in original post

232 Views
mittymcdoogle
Contributor III

I plugged a new board into my router and I'm able to connect after using that command.

Thanks!

232 Views
DavidS
NXP Employee
NXP Employee

WowWho!!!

Thanks for update.

Regards,

David

0 Kudos
232 Views
mittymcdoogle
Contributor III

Hi David,

When I type "ipconfig dhcp", I receive the following error message:

Error during dhcp bind 00001d04!

Thanks,

Mitty

0 Kudos
232 Views
danielchen
NXP TechSupport
NXP TechSupport

Hi Mitty:

Check that the devices are in the same local subnet. Or, if they are in different subnet, make sure the gateway configuration in RTCS is correct. When RTCS tries to send an IP to different network, it sends the frame via gateway.

If it does not help, could you change another board and try it again?

Daniel

0 Kudos