USB Hub support for USB2512

cancel
Showing results for 
Search instead for 
Did you mean: 

USB Hub support for USB2512

467 Views
PhilH
Contributor II

I'm starting a project to integrate some new hardware that has a USB HUB (part is USB2512) to a K60 running MQX 3.8.  I tried plugging it into the USB port but no reaction from my code.  Has anyone tried this?  Any hints on where to go to start debugging the USB side to get this to work?   I need to accesses the GPIO pins on the USB2512 part as well as a FTDI chip attached to one of the ports.

Thanks

Phil H.

Update:  After getting hardware to trace the USB bus, it was determined what the code error was and I did get it to work after patching the MQX code.  I still ran into some stability problems under stress so we abandoned this hardware strategy and removed the hub chip from our design.  I don't know if the patch will be in future MQX releases but I assume it will.

Labels (1)
Tags (2)
0 Kudos
1 Reply

92 Views
egoodii
Senior Contributor III

HUB support has 'many problems' in MQX 3.8.

0 Kudos