MQX 4.0.1 program Not Compiled with GCC

cancel
Showing results for 
Search instead for 
Did you mean: 

MQX 4.0.1 program Not Compiled with GCC

1,610 Views
yogesh8418
Contributor III

I am using TWR-K20D72M   and I opened a Sample program (Freescale\Freescale_MQX_4_0\mqx\examples\hello ) which is given in the MQX 4.0.1 Demo examples. When I choose Build tool option as  Freescale

the program compiles OK but When I choose Build tool option as GCC It gives me error.The Error is below

error

DescriptionResourcePathLocationType
mingw32-make: *** No rule to make target `C:/Freescale/Freescale_MQX_4_0/lib/twrk20d72m.cw10gcc/debug/bsp/intflash.ld', needed by `explicit-dependencies'.MQX_MODBUS_TEST1C/C++ Problem

I read somewhere  that The GCC can only work with MQX 4.0.1 and above so I am using MQX 4.0.1 .

Can some suggest me the reason for this error.How I can I remove this error.......

Thanks

Unbenannt1.png

0 Kudos
6 Replies

303 Views
c0170
Senior Contributor III

Hello yogesh patel,

what demo have you executed? Can you share console output?

How did you change compiler?

Regards,

c0170

0 Kudos

303 Views
yogesh8418
Contributor III

Hi martin

I am just executing the hello world example in the mqx example folder as shown in the picture below.

Unbenannt1.png

and the error is shown below in the picture.

Unbenannt1.png

0 Kudos

303 Views
Martin_
NXP Employee
NXP Employee

You have to build MQX libraries for GCC compiler first, before an application. Drag and drop

c:\Freescale\Freescale_MQX_4_0\config\twrk20d72m\cw10gcc\twrk20d72m.wsd

into your Project window in CW 10.4 IDE and build the MQX libraries. At post built step, the linker command file will be copied from the bsp folder to the lib folder. Then build the example application.

0 Kudos

303 Views
gionny
Contributor II

Hi. I have opened this C:\Freescale\Freescale_MQX_4_0\config\twrk70f120m\cw10gcc\twrk20d72m.wsd

and I tried to compile BSP project. The result is a lot of warnings (117).


ignoring changed section attributes for .textboot.S/psp_twrk70f120m/PSP Cortexline 52C/C++ Problem
cast from pointer to integer of different size [-Wpointer-to-int-cast]adt_kpdb.c/bsp_twrk70f120m/Peripheral IO Drivers/adc/kadcline 149C/C++ Problem
conflicting types for built-in function '_exit' [enabled by default]comp.c/psp_twrk70f120m/PSP Cortex/compilerline 43C/C++ Problem
#pragma GCC target is not supported for this machine [-Wpragmas]io_dopr.c/psp_twrk70f120m/PSP Generic/fioline 872C/C++ Problem
floating constant exceeds range of 'double' [-Woverflow] floating constant exceeds range of 'double' [-Woverflow]io_scanl.c/psp_twrk70f120m/PSP Generic/fioline 527C/C++ Problem
cast to pointer from integer of different size [-Wint-to-pointer-cast]timer_lpt.c/bsp_twrk70f120m/Peripheral IO Drivers/timerline 258C/C++ Problem
'_ksai_sine_wave' declared 'static' but never defined [-Wunused-function]sai_int_ksai.c/bsp_twrk70f120m/Peripheral IO Drivers/sai/intline 84C/C++ Problem

... ... ... ... ... ... ... ... ... ... ... ...


How Can I solve this?

Thanks

G.

0 Kudos

303 Views
Martin_
NXP Employee
NXP Employee

Hello,

warnings by MQX library build will be removed in next MQX version. For the moment, unless you make changes to the BSP source code, you may focus on your application.

0 Kudos

303 Views
gionny
Contributor II

Ok,

thanks.

So, I will wait MQX 4.1

In this moment I'm using MQX 4.0.2 + patch (FSLMQXOS_4_0_2_GA.exe + MQX_4.0.2.2_PATCH.zip)

Thanks again

Gionatha

0 Kudos