Secure Provisioning Tool: GdkPixbuf:ERROR | Aborted (core dumped)

cancel
Showing results for 
Search instead for 
Did you mean: 

Secure Provisioning Tool: GdkPixbuf:ERROR | Aborted (core dumped)

Jump to solution
84 Views
microcris
Contributor III

Hello!

I'm getting the following application output:

(securep:33145): Gtk-WARNING **: 15:31:31.257: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.
**
GdkPixbuf:ERROR:../gdk-pixbuf/io-ico.c:566:gdk_pixbuf__ico_image_begin_load: assertion failed: (size_func != NULL)
Aborted (core dumped)

Does anyone know how to solve this?

My system info:

Operating System: Kubuntu 21.04
KDE Plasma Version: 5.21.3
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.12.0-3-generic
OS Type: 64-bit
Graphics Platform: X11
Processors: 8 × Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Memory: 15,5 GiB of RAM
Graphics Processor: GeForce GTX 1050/PCIe/SSE2

0 Kudos
1 Solution
79 Views
b23204
NXP Employee
NXP Employee

Hi microcris,

ubuntu 20.04 is not supported yet in v2.1. It is planned to be supported in next version (v3.0).

Please mind, supported operating systems are described in ReleaseNotes.txt

Regards
Marek Trmac

Regards,
Marek

View solution in original post

0 Kudos
3 Replies
80 Views
b23204
NXP Employee
NXP Employee

Hi microcris,

ubuntu 20.04 is not supported yet in v2.1. It is planned to be supported in next version (v3.0).

Please mind, supported operating systems are described in ReleaseNotes.txt

Regards
Marek Trmac

Regards,
Marek

View solution in original post

0 Kudos
73 Views
microcris
Contributor III

Thank you @b23204 for your reply.

It is indeed a compatibility problem. 
Just to prove your point, I replaced all pixbuf packages in my Ubuntu installation by the ones provided by Ubuntu 18.04 and it made Secure Provisioning Tool work properly. Obviously replacing my system pixbuf packages by older ones breaks a lot of stuff and it is no solution. 

I'm going to try to manually run the scripts that are in "tools_scritps" folder to prepare the flash image and load int in to may device. It would be nice if you could provide a FlashLoader package for LPC55XX like you do for i.mxRT10XX.

0 Kudos
64 Views
liborukropec
NXP Employee
NXP Employee

Hi @microcris,

you could try to run the securep in the terminal (see ./securep --help) this way the GUI won't be required and thus won't fail. I guess it will be better than manually play with the tools_scripts because you will be ready to use the GUI fully with the next 3.0 version. Also you might try to install Ubuntu 18.04 LTS in the VM if you have to stick with KDE.

 

Regards,

Libor

0 Kudos